tools/libressl: ensure PIC-only object compilation
authorMichael Pratt <mcpratt@pm.me>
Wed, 20 Jul 2022 23:14:10 +0000 (19:14 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 31 Jul 2022 16:46:23 +0000 (18:46 +0200)
Line up configure arguments for cleaner git diff and editing and grepping.

LibreSSL must be built with PIC, and has the flags for it already in CFLAGS.
Add the configure option native to LibreSSL to use only PIC in objects,
which further enforces that each object in the library has the PIC flag
to prevent a mixture of PIC / non-PIC objects within it.

Ref: 96a940308 ("tools: libressl: always build as PIC")
Signed-off-by: Michael Pratt <mcpratt@pm.me>
tools/libressl/Makefile

index 236a7c2c307510b9589fdee896c798530ec5de3f..aecc788972992c540189dee0f026eae7faff7aaa 100644 (file)
@@ -24,9 +24,15 @@ HOST_BUILD_PARALLEL:=1
 include $(INCLUDE_DIR)/host-build.mk
 
 HOSTCC := $(HOSTCC_NOCACHE)
-HOST_CONFIGURE_ARGS += --enable-static --disable-shared --disable-tests
+
 HOST_CFLAGS += $(HOST_FPIC)
 
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --with-pic \
+       --disable-tests
+
 ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
 HOST_CONFIGURE_ARGS += --disable-asm
 endif