build: use ONESHELL to speed up scanning and the toplevel makefile
authorFelix Fietkau <nbd@openwrt.org>
Wed, 22 Oct 2014 08:57:40 +0000 (08:57 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 22 Oct 2014 08:57:40 +0000 (08:57 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 43021

Makefile
include/scan.mk
include/target.mk

index 91b6946ac3420c8d7272807a809bb418f3f99103..f75fc7fda4d735fcb4b08213ee9a44087d6603a1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -15,6 +15,7 @@ empty:=
 space:= $(empty) $(empty)
 $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
 
+.ONESHELL:
 world:
 
 include $(TOPDIR)/include/host.mk
index 0998333439af518a24d3e104f1a177e6fd365599..2f2753f2a01069ccc20466c9b16a35d0ac4efad2 100644 (file)
@@ -78,3 +78,4 @@ $(TMP_DIR)/.$(SCAN_TARGET): $(TARGET_STAMP) $(SCAN_STAMP)
 FORCE:
 .PHONY: FORCE
 .NOTPARALLEL:
+.ONESHELL:
index 3401f849a5fdd3980b4edd938eee786d0df4eab1..657109e75d398316251f08ef92f904d487b22343 100644 (file)
@@ -19,6 +19,7 @@ DEFAULT_PACKAGES.bootloader:=
 
 ifneq ($(DUMP),)
   all: dumpinfo
+  .ONESHELL:
 endif
 
 target_conf=$(subst .,_,$(subst -,_,$(subst /,_,$(1))))