build: conditionally enable testing-kernel feature
authorDavid Bauer <mail@david-bauer.net>
Tue, 7 Jul 2020 08:32:09 +0000 (10:32 +0200)
committerDavid Bauer <mail@david-bauer.net>
Tue, 7 Jul 2020 08:32:09 +0000 (10:32 +0200)
Only enable the testing-kernel feature for the target when the testing
kernel version does not match the stable kernel version.

This way, the option for building the testing kernel in the build config
menu is only exposed when there's a testing kernel available.

Signed-off-by: David Bauer <mail@david-bauer.net>
Acked-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
include/target.mk

index a2ceb7f783f363e6a40598161c68f245a155d5df..64292138b7ad1548819bce16c734e1fbbffd1c43 100644 (file)
@@ -223,7 +223,9 @@ ifeq ($(DUMP),1)
     .PRECIOUS: $(TMP_CONFIG)
 
     ifdef KERNEL_TESTING_PATCHVER
-      FEATURES += testing-kernel
+      ifneq ($(KERNEL_TESTING_PATCHVER),$(KERNEL_PATCHVER))
+        FEATURES += testing-kernel
+      endif
     endif
     ifneq ($(CONFIG_OF),)
       FEATURES += dt