add a gpio feature for devices supporting the generic GPIO interface
authorNicolas Thill <nico@openwrt.org>
Sun, 20 Apr 2008 09:46:45 +0000 (09:46 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 20 Apr 2008 09:46:45 +0000 (09:46 +0000)
SVN-Revision: 10879

include/target.mk
scripts/metadata.pl
target/Config.in

index 4f10a3db2bf19a2606b7d2487f550295649e261c..ce842da7951e469d2f994d1b51ed313d5d1a7611 100644 (file)
@@ -126,6 +126,9 @@ ifeq ($(DUMP),1)
     .SILENT: $(TMP_CONFIG)
     .PRECIOUS: $(TMP_CONFIG)
 
+    ifneq ($(CONFIG_GENERIC_GPIO),)
+      FEATURES += gpio
+    endif
     ifneq ($(CONFIG_PCI),)
       FEATURES += pci
     endif
index 6d7534519675f95631b2323e6850ef3ecc41e140..51dcc425baa205e0eebc513fc61a7419be4322b0 100755 (executable)
@@ -152,6 +152,7 @@ sub target_config_features(@) {
        while ($_ = shift @_) {
                /broken/ and $ret .= "\tdepends BROKEN\n";
                /display/ and $ret .= "\tselect DISPLAY_SUPPORT\n";
+               /gpio/ and $ret .= "\tselect GPIO_SUPPORT\n";
                /pci/ and $ret .= "\tselect PCI_SUPPORT\n";
                /usb/ and $ret .= "\tselect USB_SUPPORT\n";
                /pcmcia/ and $ret .= "\tselect PCMCIA_SUPPORT\n";
index aabe9c3034e9de6e50f80fea8202e5a117d3a90f..505fcc9621175ce608ab8a862c639c534c8a14e8 100644 (file)
@@ -11,6 +11,9 @@ config LINUX_2_6
 config DISPLAY_SUPPORT
        bool
 
+config GPIO_SUPPORT
+       bool
+
 config PCI_SUPPORT
        bool