layerscape: rename Traverse boards along SoC lines
authorMathew McBride <matt@traverse.com.au>
Tue, 26 Feb 2019 06:47:42 +0000 (17:47 +1100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 10 Mar 2019 16:48:23 +0000 (17:48 +0100)
Upcoming product specification and branding changes mean that the names in tree do not accurately reflect released products.
To reduce any confusion, sort our boards by SoC family, e.g traverse-ls1043. Any future boards using Layerscape family SoC's
will be treated the same way, e.g Device/traverse-ls/lx/laXXXX.
The affected boards so far have only been available through OEM channels and those aren't using the provided sysupgrade.

Signed-off-by: Mathew McBride <matt@traverse.com.au>
target/linux/layerscape/image/Makefile
target/linux/layerscape/image/armv8_64b.mk

index a08cc2c2cbbc1b56bebe732c3dd4f47cd703988d..884daa5c216e80b51428451fc49958f202ac4d08 100644 (file)
@@ -7,8 +7,6 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-ITB_BOARDS = traverse-five64
-
 LS_SD_ROOTFSPART_OFFSET = 64
 LS_SD_IMAGE_SIZE = $(shell echo $$((($(LS_SD_ROOTFSPART_OFFSET) + \
        $(CONFIG_TARGET_ROOTFS_PARTSIZE)) * 1024 * 1024)))
index 6d783a58db2b375cb86e1fb87834c2e2c16003af..5f3a511978a7413040d84b58d500d6ef22acffba 100644 (file)
@@ -231,18 +231,18 @@ define Device/ls2088ardb
 endef
 TARGET_DEVICES += ls2088ardb
 
-define Device/traverse-five64
+define Device/traverse-ls1043
   KERNEL_NAME := Image
   KERNEL_SUFFIX := -kernel.itb
   KERNEL_INSTALL := 1
   FDT_LOADADDR = 0x90000000
   FILESYSTEMS := ubifs
-  DEVICE_TITLE := Traverse LS1043 Boards (Five64, LS1043S)
+  DEVICE_TITLE := Traverse LS1043 Boards
   DEVICE_PACKAGES += \
     layerscape-fman-ls1043ardb \
-    uboot-envtools uboot-traverse-ls1043v uboot-traverse-ls1043v-sdcard \
+    uboot-envtools \
     kmod-i2c-core kmod-i2c-mux-pca954x \
-    kmod-hwmon-core kmod-hwmon-ltc2990 kmod-hwmon-pac1934 kmod-hwmon-emc17xx\
+    kmod-hwmon-core \
     kmod-gpio-pca953x kmod-input-gpio-keys-polled \
     kmod-rtc-isl1208
   DEVICE_DESCRIPTION = \
@@ -253,9 +253,9 @@ define Device/traverse-five64
   DEVICE_DTS_CONFIG = ls1043s
   KERNEL := kernel-bin | gzip | traverse-fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb $$(FDT_LOADADDR)
   KERNEL_INITRAMFS := kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb $$(FDT_LOADADDR)
-  IMAGES = root sysupgrade.tar
+  IMAGES = root sysupgrade.bin
   IMAGE/root = append-rootfs
-  IMAGE/sysupgrade.tar = sysupgrade-tar
+  IMAGE/sysupgrade.bin = sysupgrade-tar | append-metadata
   MKUBIFS_OPTS := -m 2048 -e 124KiB -c 4096
 endef
-TARGET_DEVICES += traverse-five64
+TARGET_DEVICES += traverse-ls1043