wolfssl: fix build in busybox environments
authorMoritz Warning <moritzwarning@web.de>
Tue, 5 Mar 2019 21:22:41 +0000 (22:22 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 10 Mar 2019 16:48:23 +0000 (17:48 +0100)
The configure script broke when used in alpine-3.9 based docker containers. Fixed in wolfSSL >3.15.7.

Signed-off-by: Moritz Warning <moritzwarning@web.de>
package/libs/wolfssl/patches/101-AR-flags-configure-update.patch [new file with mode: 0644]
package/libs/wolfssl/patches/900-remove-broken-autoconf-macros.patch

diff --git a/package/libs/wolfssl/patches/101-AR-flags-configure-update.patch b/package/libs/wolfssl/patches/101-AR-flags-configure-update.patch
new file mode 100644 (file)
index 0000000..9401a54
--- /dev/null
@@ -0,0 +1,23 @@
+From 42eacece82b6375a9f4bab3903a1a39f7d1dd579 Mon Sep 17 00:00:00 2001
+From: John Safranek <john@wolfssl.com>
+Date: Tue, 5 Mar 2019 09:26:30 -0800
+Subject: [PATCH] AR flags configure update In at least one environment the
+ check for particular AR options was failing due to a bash script bug. Deleted
+ an extra pair of parenthesis triggering an arithmetic statement when
+ redundant grouping was desired.
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -15,7 +15,7 @@ AC_CONFIG_AUX_DIR([build-aux])
+ : ${CFLAGS=""}
+ # Test ar for the "U" option. Should be checked before the libtool macros.
+-xxx_ar_flags=$((ar --help) 2>&1)
++xxx_ar_flags=$(ar --help 2>&1)
+ AS_CASE([$xxx_ar_flags],[*'use actual timestamps and uids/gids'*],[: ${AR_FLAGS="Ucru"}])
+ AC_PROG_CC
index f7756b11c62a88bb1fae240a461865b294b18706..66582cfc469c2fd96119a27fab71fa5062e911ca 100644 (file)
@@ -1,7 +1,7 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -4140,7 +4140,6 @@ AC_CONFIG_FILES([support/wolfssl.pc])
- AC_CONFIG_FILES([rpm/spec])
+@@ -4198,7 +4198,6 @@ AC_CONFIG_FILES([stamp-h], [echo timesta
+ AC_CONFIG_FILES([Makefile wolfssl/version.h wolfssl/options.h cyassl/options.h support/wolfssl.pc rpm/spec])
  
  AX_CREATE_GENERIC_CONFIG
 -AX_AM_JOBSERVER([yes])