procd: update to latest git HEAD
[openwrt/staging/wigyori.git] / package / libs / libnl / patches / 100-build-add-Libs.private-field-in-libnl-pkg-config-file.patch
1 From db0d59cd06f3ffd350379847c0885e1bfb85af0f Mon Sep 17 00:00:00 2001
2 From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
3 Date: Sat, 7 Mar 2015 11:34:42 +0100
4 Subject: [PATCH 2/2] build: add Libs.private field in libnl pkg-config file
5
6 In order to support static linking, the libnl pkg-config file should
7 indicate in its Libs.private field the libraries that libnl-3.0.a
8 requires. The LIBS variable contains the appropriate list of
9 libraries: -lm in all cases, and -lpthread when pthread support is
10 enabled. This allows to statically link applications against libnl
11 properly.
12
13 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
14 ---
15 libnl-3.0.pc.in | 1 +
16 1 file changed, 1 insertion(+)
17
18 --- a/libnl-3.0.pc.in
19 +++ b/libnl-3.0.pc.in
20 @@ -7,4 +7,5 @@ Name: libnl
21 Description: Convenience library for netlink sockets
22 Version: @PACKAGE_VERSION@
23 Libs: -L${libdir} -lnl-@MAJ_VERSION@
24 +Libs.private: @LIBS@
25 Cflags: -I${includedir}/libnl@MAJ_VERSION@