busybox: update to 1.28.2
[openwrt/staging/wigyori.git] / package / utils / busybox / patches / 510-move-passwd-applet-to-bin.patch
1 --- a/loginutils/passwd.c
2 +++ b/loginutils/passwd.c
3 @@ -23,7 +23,7 @@
4 //config: With this option passwd will refuse new passwords which are "weak".
5
6 //applet:/* Needs to be run by root or be suid root - needs to change /etc/{passwd,shadow}: */
7 -//applet:IF_PASSWD(APPLET(passwd, BB_DIR_USR_BIN, BB_SUID_REQUIRE))
8 +//applet:IF_PASSWD(APPLET(passwd, BB_DIR_BIN, BB_SUID_REQUIRE))
9
10 //kbuild:lib-$(CONFIG_PASSWD) += passwd.o
11