at91: add support for the WB50N module from Laird
[openwrt/staging/wigyori.git] / toolchain / gcc / patches / 5.4.0 / 230-musl_libssp.patch
1 --- a/gcc/gcc.c
2 +++ b/gcc/gcc.c
3 @@ -727,7 +727,9 @@ proper position among the other output f
4 #endif
5
6 #ifndef LINK_SSP_SPEC
7 -#ifdef TARGET_LIBC_PROVIDES_SSP
8 +#if DEFAULT_LIBC == LIBC_MUSL
9 +#define LINK_SSP_SPEC "-lssp_nonshared"
10 +#elif defined(TARGET_LIBC_PROVIDES_SSP)
11 #define LINK_SSP_SPEC "%{fstack-protector|fstack-protector-all" \
12 "|fstack-protector-strong|fstack-protector-explicit:}"
13 #else