tools/xz enable parallel builds
[openwrt/staging/wigyori.git] / Makefile
index 7e43b443219fda97ed5f4363e04d680cea337599..44b4e944eb9b5a46d68786d8a5473f9455589690 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -20,10 +20,12 @@ ifneq ($(OPENWRT_BUILD),1)
   # but we can't include that file in this context
   empty:=
   space:= $(empty) $(empty)
-  _SINGLE=MAKEFLAGS=$(space)
+  _SINGLE=export MAKEFLAGS=$(space);
 
   override OPENWRT_BUILD=1
   export OPENWRT_BUILD
+  GREP_OPTIONS=
+  export GREP_OPTIONS
   include $(TOPDIR)/include/debug.mk
   include $(TOPDIR)/include/depends.mk
   include $(TOPDIR)/include/toplevel.mk
@@ -44,35 +46,48 @@ $(package/stamp-install): $(package/stamp-compile)
 $(package/stamp-rootfs-prepare): $(package/stamp-install)
 $(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare)
 
-$(BUILD_DIR)/.prepared: Makefile
-       @mkdir -p $$(dirname $@)
-       @touch $@
+printdb:
+       @true
+
+prepare: $(target/stamp-compile)
 
 clean: FORCE
-       rm -rf $(BUILD_DIR) $(BIN_DIR)
-       $(SUBMAKE) target/linux/clean
+       $(_SINGLE)$(SUBMAKE) target/linux/clean
+       rm -rf $(BUILD_DIR) $(BIN_DIR) $(BUILD_LOG_DIR)
 
 dirclean: clean
-       rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST)
+       rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST) $(BUILD_DIR_TOOLCHAIN)
        rm -rf $(TMP_DIR)
 
+ifndef DUMP_TARGET_DB
+$(BUILD_DIR)/.prepared: Makefile
+       @mkdir -p $$(dirname $@)
+       @touch $@
+
 tmp/.prereq_packages: .config
        unset ERROR; \
        for package in $(sort $(prereq-y) $(prereq-m)); do \
-               $(NO_TRACE_MAKE) -s -r -C package/$$package prereq || ERROR=1; \
+               $(_SINGLE)$(NO_TRACE_MAKE) -s -r -C package/$$package prereq || ERROR=1; \
        done; \
        if [ -n "$$ERROR" ]; then \
                echo "Package prerequisite check failed."; \
                false; \
        fi
        touch $@
+endif
 
 # check prerequisites before starting to build
 prereq: $(target/stamp-prereq) tmp/.prereq_packages
+       @if [ ! -f "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" ]; then \
+               echo 'ERROR: Missing site config for target "$(REAL_GNU_TARGET_NAME)" !'; \
+               echo '       The missing file will cause configure scripts to fail during compilation.'; \
+               echo '       Please provide a "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" file and restart the build.'; \
+               exit 1; \
+       fi
 
 prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
 world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
-       $(SUBMAKE) package/index
+       $(_SINGLE)$(SUBMAKE) -r package/index
 
 # update all feeds, re-create index files, install symlinks
 package/symlinks: