fix unwanted automatic package cleaning when using quilt
[openwrt/staging/wigyori.git] / include / quilt.mk
index 47195293e881df9b28fe9b0faa5a56956d16cc9e..86008e2f14e7349e585b4fdb0099c65d2a98ec06 100644 (file)
@@ -8,6 +8,7 @@
 ifeq ($(KERNEL_BUILD),1)
   PKG_BUILD_DIR:=$(LINUX_DIR)
 endif
+PATCH_DIR?=./patches
 
 define Quilt/Patch
        @for patch in $$$$( (cd $(1) && ls) 2>/dev/null ); do ( \
@@ -23,12 +24,12 @@ QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
 ifneq ($(QUILT),)
   STAMP_PREPARED:=$(strip $(STAMP_PREPARED))_q
   STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
-  CONFIG_AUTOREBUILD=
+  override CONFIG_AUTOREBUILD=
   PATCHES:=$(shell )
   define Build/Patch/Default
        rm -rf $(PKG_BUILD_DIR)/patches
        mkdir -p $(PKG_BUILD_DIR)/patches
-       $(call Quilt/Patch,./patches,)
+       $(call Quilt/Patch,$(PATCH_DIR),)
        @echo
        touch $(PKG_BUILD_DIR)/.quilt_used
   endef
@@ -37,8 +38,8 @@ ifneq ($(QUILT),)
   quilt-check: $(STAMP_PATCHED)
 else
   define Build/Patch/Default
-       @if [ -d ./patches -a "$$$$(ls ./patches | wc -l)" -gt 0 ]; then \
-               $(PATCH) $(PKG_BUILD_DIR) ./patches; \
+       @if [ -d $(PATCH_DIR) -a "$$$$(ls $(PATCH_DIR) | wc -l)" -gt 0 ]; then \
+               $(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
        fi
   endef
 endif
@@ -75,7 +76,7 @@ define Quilt/RefreshDir
 endef
 
 define Quilt/Refresh/Package
-       $(call Quilt/RefreshDir,./patches)
+       $(call Quilt/RefreshDir,$(PATCH_DIR))
 endef
 
 define Quilt/Refresh/Kernel