add optional version suffix to kernel files/ directories
[openwrt/staging/wigyori.git] / include / quilt.mk
index 667653f320b30f6d096dbbf739d00243510850b5..c310fd99acd2081a572dc96f1a4be1dd0feeb3e2 100644 (file)
@@ -12,6 +12,7 @@ ifeq ($(TARGET_BUILD),1)
   PKG_BUILD_DIR:=$(LINUX_DIR)
 endif
 PATCH_DIR?=./patches
+FILES_DIR?=./files
 
 ifeq ($(MAKECMDGOALS),refresh)
   override QUILT=1
@@ -23,8 +24,8 @@ endef
 
 define PatchDir/Quilt
        @if [ -s $(1)/series ]; then \
-               mkdir -p $(PKG_BUILD_DIR)/patches$(if $(2),/$(2)); \
-               cp $(1)/series $(PKG_BUILD_DIR)/patches$(if $(2),/$(2))/; \
+               mkdir -p $(PKG_BUILD_DIR)/patches/$(2); \
+               cp $(1)/series $(PKG_BUILD_DIR)/patches/$(2); \
        fi
        @for patch in $$$$( (cd $(1) && if [ -f series ]; then $(call filter_series,series); else ls; fi; ) 2>/dev/null ); do ( \
                cp "$(1)/$$$$patch" $(PKG_BUILD_DIR); \
@@ -54,10 +55,10 @@ endef
 QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
 ifneq ($(QUILT),)
   STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
+  STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
   override CONFIG_AUTOREBUILD=
-  $(STAMP_CONFIGURED): $(STAMP_PATCHED) FORCE
   prepare: $(STAMP_PATCHED)
-  quilt-check: $(STAMP_PATCHED)
+  quilt-check: $(STAMP_CHECKED)
 endif
 
 define Build/Patch/Default
@@ -67,8 +68,11 @@ endef
 
 define Kernel/Patch/Default
        $(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
-       if [ -d $(GENERIC_PLATFORM_DIR)/files ]; then $(CP) $(GENERIC_PLATFORM_DIR)/files/* $(LINUX_DIR)/; fi
-       if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
+       if [ -d $(GENERIC_FILES_DIR) ]; then $(CP) $(GENERIC_FILES_DIR)/* $(LINUX_DIR)/; fi
+       if [ -d $(FILES_DIR) ]; then \
+               $(CP) $(FILES_DIR)/* $(LINUX_DIR)/; \
+               find $(LINUX_DIR)/ -name \*.rej | xargs rm -f; \
+       fi
        $(call PatchDir,$(GENERIC_PATCH_DIR),generic/)
        $(call PatchDir,$(PATCH_DIR),platform/)
 endef
@@ -100,29 +104,33 @@ define Quilt/Refresh
 $(if $(TARGET_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
 endef
 
-$(STAMP_PATCHED): $(STAMP_PREPARED)
+define Build/Quilt
+  $(STAMP_PATCHED): $(STAMP_PREPARED)
        @( \
                cd $(PKG_BUILD_DIR)/patches; \
                quilt pop -a -f >/dev/null 2>/dev/null; \
                if [ -s ".subdirs" ]; then \
                        rm -f series; \
-                       for file in $$(cat .subdirs); do \
-                               if [ -f $$file/series ]; then \
+                       for file in $$$$(cat .subdirs); do \
+                               if [ -f $$$$file/series ]; then \
                                        echo "Converting $$file/series"; \
-                                       $(call filter_series,$$file/series) | awk -v file="$$file/" '$$0 !~ /^#/ { print file $$0 }' >> series; \
+                                       $$(call filter_series,$$$$file/series) | awk -v file="$$$$file/" '$$$$0 !~ /^#/ { print file $$$$0 }' | sed -e s,//,/,g >> series; \
                                else \
-                                       echo "Sorting patches in $$file"; \
-                                       find $$file/* -type f \! -name series | sort >> series; \
+                                       echo "Sorting patches in $$$$file"; \
+                                       find $$$$file/* -type f \! -name series | sed -e s,//,/,g | sort >> series; \
                                fi; \
                        done; \
                else \
                        find * -type f \! -name series | sort > series; \
                fi; \
        )
-       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
-       touch $@
+       touch $$@
+
+  $(STAMP_CONFIGURED): $(STAMP_CHECKED) FORCE
+  $(STAMP_CHECKED): $(STAMP_PATCHED)
+       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt next >/dev/null 2>&1 && quilt push -a || quilt top >/dev/null 2>&1); fi
+       touch $$@
 
-define Build/Quilt
   quilt-check: $(STAMP_PREPARED) FORCE
        @[ -f "$(PKG_BUILD_DIR)/.quilt_used" ] || { \
                echo "The source directory was not unpacked using quilt. Please rebuild with QUILT=1"; \