image.mk: fix emitting profiles for targets that have no subtargets
[openwrt/staging/wigyori.git] / include / target.mk
index 08e0a62af64eaab81e839be56156dc07149a04b0..0666df63a157f3d8d3f08b60836e90a360b4ee4e 100644 (file)
@@ -274,7 +274,7 @@ endif
 
 CUR_SUBTARGET:=$(SUBTARGET)
 ifeq ($(SUBTARGETS),)
-  CUR_SUBTARGET ?= default
+  CUR_SUBTARGET := default
 endif
 
 define BuildTargets/DumpCurrent