let ipkg fail when a package file to be installed is not found
[openwrt/staging/wigyori.git] / openwrt / package / pptpd / Makefile
index de12556efbd6a651bb8220ee4374b2c3f6f4569d..34d2229ab97afa6271e3391e0356fb62219ab883 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pptpd
-PKG_VERSION:=1.2.3
-PKG_RELEASE:=1
-PKG_MD5SUM:=a521e40ca304b0c125cc25f9b9d03324
+PKG_VERSION:=1.3.0
+PKG_RELEASE:=2
+PKG_MD5SUM:=75d494e881f7027f4e60b114163f6b67
 
 PKG_SOURCE_URL:=@SF/poptop
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -59,11 +59,11 @@ $(IPKG_PPTPD):
        install -d -m0755 $(IDIR_PPTPD)/etc
        install -m0644 ./files/pptpd.conf $(IDIR_PPTPD)/etc/
        install -d -m0755 $(IDIR_PPTPD)/etc/init.d
-       install -m0644 ./files/pptpd.init $(IDIR_PPTPD)/etc/init.d/pptpd
+       install -m0755 ./files/pptpd.init $(IDIR_PPTPD)/etc/init.d/pptpd
        install -d -m0755 $(IDIR_PPTPD)/etc/ppp
        install -m0644 ./files/options.pptpd $(IDIR_PPTPD)/etc/ppp/
        install -d -m0755 $(IDIR_PPTPD)/usr/sbin
-       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/pptpd $(IDIR_PPTPD)/usr/sbin/
-       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl $(IDIR_PPTPD)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpd $(IDIR_PPTPD)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl $(IDIR_PPTPD)/usr/sbin/
        $(RSTRIP) $(IDIR_PPTPD)
        $(IPKG_BUILD) $(IDIR_PPTPD) $(PACKAGE_DIR)