layerscape: add 64b/32b target for ls1046ardb device
[openwrt/staging/wigyori.git] / package / boot / uboot-layerscape-32b / Makefile
index d6a6d2654a858d372d7ee29253308590f020567c..f6191866859ec4332736b52224ec349d8ddc2aa0 100644 (file)
@@ -16,7 +16,7 @@ PKG_SOURCE_PROTO:=git
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=https://github.com/fsl-jyt/uboot-ls-32b.git
-PKG_SOURCE_VERSION:=4fbf7e76eb7671d9822d0310319f6ad70d324547
+PKG_SOURCE_VERSION:=763de09cc7265e3147e2df2e15f91c73231907f4
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -35,8 +35,20 @@ define uboot/ls1043ardb
        CONFIG=ls1043ardb-uboot.bin
 endef
 
+define uboot/ls1046ardb
+       TITLE:=U-Boot binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1046ardb 32b Dev Board
+       CONFIG=ls1046ardb-uboot.bin
+endef
+
+define uboot/ls1012ardb
+       TITLE:=U-Boot binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1012ardb 32b Dev Board
+       CONFIG=ls1012ardb-uboot.bin.swap
+endef
+
 UBOOTS := \
-       ls1043ardb
+       ls1043ardb \
+       ls1046ardb \
+       ls1012ardb
 
 define Package/uboot/template
 define Package/uboot-layerscape-32b-$(1)