sunxi: Added support for Xunlong Orange Pi PC2
[openwrt/staging/wigyori.git] / package / boot / uboot-sunxi / Makefile
index 7773e340c139e71acad07d9472688f8efba02007..ce5edfc1b62c4b7833e58e3ac257f9d633bbfed5 100644 (file)
@@ -207,6 +207,14 @@ define U-Boot/orangepi_zero_plus
   UENV:=a64
 endef
 
+define U-Boot/orangepi_pc2
+  BUILD_SUBTARGET:=cortexa53
+  NAME:=Xunlong Orange Pi PC2
+  BUILD_DEVICES:=sun50i-h5-orangepi-pc2
+  DEPENDS:=+PACKAGE_u-boot-orangepi_pc2:arm-trusted-firmware-sunxi
+  UENV:=a64
+endef
+
 UBOOT_TARGETS := \
        A10-OLinuXino-Lime \
        A13-OLinuXino \
@@ -233,6 +241,7 @@ UBOOT_TARGETS := \
        orangepi_pc \
        orangepi_plus \
        orangepi_2 \
+       orangepi_pc2 \
        pangolin \
        pine64_plus \
        sopine_baseboard \