oprofile: drop kmod-oprofile dependency, it uses the perf API now
[openwrt/staging/wigyori.git] / package / devel / oprofile / Makefile
index c758cbc4d33088e1837dc96d265aa369c24c1bad..cdeeec2e98aca8998cd692ec4ca896c591562f55 100644 (file)
@@ -8,19 +8,21 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oprofile
-PKG_VERSION:=0.9.9
+PKG_VERSION:=1.1.0rc2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/oprofile/
-PKG_MD5SUM:=00aec1287da2dfffda17a9b1c0a01868
+PKG_MD5SUM:=ebc27a8478068cb986efd295cc4ac877
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
 PKG_BUILD_DEPENDS:=binutils
+PKG_LICENSE:=GPL-2.0+
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
+PKG_USE_MIPS16:=0
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -30,7 +32,7 @@ define Package/oprofile
   CATEGORY:=Development
   TITLE:=OProfile System Profiler
   URL:=http://oprofile.sourceforge.net
-  DEPENDS:=+libpopt +kmod-oprofile +libstdcpp +objdump
+  DEPENDS:=+libpopt +libstdcpp +objdump +librt @(!TARGET_uml||BROKEN)
 endef
 
 define Package/oprofile/description
@@ -48,6 +50,7 @@ endef
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-kernel-support \
+               --with-kernel=$(LINUX_DIR)/user_headers \
                --without-x \
        )
 endef