package/dnsmasq: update to 2.59 (thanks to Raphael Huck)
[openwrt/staging/wigyori.git] / package / dnsmasq / Makefile
index 977e1097097545aacda8e8acecebd2a5caf19e58..1f99b5014b3d3fd3a5f644fbaf2b8eddfaf8af97 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2010 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.55
-PKG_RELEASE:=3
+PKG_VERSION:=2.59
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=b093d7c6bc7f97ae6fd35d048529232a
+PKG_MD5SUM:=b5757ef2d7b651748eeebb88af29d7d6
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,7 +27,7 @@ define Package/dnsmasq
 endef
 
 define Package/dnsmasq/description
- It is intended to provide coupled DNS and DHCP service to a LAN.
 It is intended to provide coupled DNS and DHCP service to a LAN.
 endef
 
 define Package/dnsmasq/conffiles
@@ -33,18 +35,17 @@ define Package/dnsmasq/conffiles
 /etc/dnsmasq.conf
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               BINDIR="/usr/sbin" MANDIR="/usr/man" \
-               AWK="awk" \
-               all
-endef
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+
+MAKE_FLAGS := \
+       $(TARGET_CONFIGURE_OPTS) \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       LDFLAGS="-Wl,--gc-sections" \
+       PREFIX="/usr"
 
 define Package/dnsmasq/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/dnsmasq $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/dhcp.conf $(1)/etc/config/dhcp
        $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf