hostapd: update to 2011-02-21, use PKG_MIRROR_MD5SUM, includes fixes for WPS
[openwrt/staging/wigyori.git] / package / hostapd / patches / 560-disable_ctrl_iface_mib.patch
index b71d307974d54eeb6aad28a41d451f9206a0b1bd..f186235cba30da17c9d5c09df9ac7cb05151e1b2 100644 (file)
  endif
 --- a/hostapd/ctrl_iface.c
 +++ b/hostapd/ctrl_iface.c
-@@ -852,6 +852,7 @@ static void hostapd_ctrl_iface_receive(i
-       if (os_strcmp(buf, "PING") == 0) {
-               os_memcpy(reply, "PONG\n", 5);
-               reply_len = 5;
+@@ -855,6 +855,7 @@ static void hostapd_ctrl_iface_receive(i
+       } else if (os_strncmp(buf, "RELOG", 5) == 0) {
+               if (wpa_debug_reopen_file() < 0)
+                       reply_len = -1;
 +#ifdef CONFIG_CTRL_IFACE_MIB
        } else if (os_strcmp(buf, "MIB") == 0) {
                reply_len = ieee802_11_get_mib(hapd, reply, reply_size);
                if (reply_len >= 0) {
-@@ -881,10 +882,12 @@ static void hostapd_ctrl_iface_receive(i
+@@ -884,10 +885,12 @@ static void hostapd_ctrl_iface_receive(i
                                reply_len += res;
                }
  #endif /* CONFIG_NO_RADIUS */
@@ -33,7 +33,7 @@
        } else if (os_strcmp(buf, "STA-FIRST") == 0) {
                reply_len = hostapd_ctrl_iface_sta_first(hapd, reply,
                                                         reply_size);
-@@ -894,6 +897,7 @@ static void hostapd_ctrl_iface_receive(i
+@@ -897,6 +900,7 @@ static void hostapd_ctrl_iface_receive(i
        } else if (os_strncmp(buf, "STA-NEXT ", 9) == 0) {
                reply_len = hostapd_ctrl_iface_sta_next(hapd, buf + 9, reply,
                                                        reply_size);
@@ -43,7 +43,7 @@
                        reply_len = -1;
 --- a/wpa_supplicant/Makefile
 +++ b/wpa_supplicant/Makefile
-@@ -668,6 +668,9 @@ ifdef CONFIG_IEEE80211N
+@@ -675,6 +675,9 @@ ifdef CONFIG_IEEE80211N
  OBJS += ../src/ap/ieee802_11_ht.o
  endif
  ifdef CONFIG_CTRL_IFACE
  
 --- a/wpa_supplicant/ctrl_iface.c
 +++ b/wpa_supplicant/ctrl_iface.c
-@@ -2788,6 +2788,7 @@ char * wpa_supplicant_ctrl_iface_process
-               reply_len = 5;
+@@ -2885,6 +2885,7 @@ char * wpa_supplicant_ctrl_iface_process
+                       reply_len = -1;
        } else if (os_strncmp(buf, "NOTE ", 5) == 0) {
                wpa_printf(MSG_INFO, "NOTE: %s", buf + 5);
 +#ifdef CONFIG_CTRL_IFACE_MIB
        } else if (os_strcmp(buf, "MIB") == 0) {
                reply_len = wpa_sm_get_mib(wpa_s->wpa, reply, reply_size);
                if (reply_len >= 0) {
-@@ -2799,6 +2800,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -2896,6 +2897,7 @@ char * wpa_supplicant_ctrl_iface_process
                        else
                                reply_len += res;
                }
@@ -71,7 +71,7 @@
        } else if (os_strncmp(buf, "STATUS", 6) == 0) {
                reply_len = wpa_supplicant_ctrl_iface_status(
                        wpa_s, buf + 6, reply, reply_size);
-@@ -3083,6 +3085,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -3189,6 +3191,7 @@ char * wpa_supplicant_ctrl_iface_process
                reply_len = wpa_supplicant_ctrl_iface_bss(
                        wpa_s, buf + 4, reply, reply_size);
  #ifdef CONFIG_AP
@@ -79,7 +79,7 @@
        } else if (os_strcmp(buf, "STA-FIRST") == 0) {
                reply_len = ap_ctrl_iface_sta_first(wpa_s, reply, reply_size);
        } else if (os_strncmp(buf, "STA ", 4) == 0) {
-@@ -3091,6 +3094,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -3197,6 +3200,7 @@ char * wpa_supplicant_ctrl_iface_process
        } else if (os_strncmp(buf, "STA-NEXT ", 9) == 0) {
                reply_len = ap_ctrl_iface_sta_next(wpa_s, buf + 9, reply,
                                                   reply_size);
 +#endif
 --- a/src/ap/ieee802_1x.c
 +++ b/src/ap/ieee802_1x.c
-@@ -1848,6 +1848,7 @@ static const char * bool_txt(Boolean boo
+@@ -1866,6 +1866,7 @@ static const char * bool_txt(Boolean boo
        return bool ? "TRUE" : "FALSE";
  }
  
  
  int ieee802_1x_get_mib(struct hostapd_data *hapd, char *buf, size_t buflen)
  {
-@@ -1999,6 +2000,7 @@ int ieee802_1x_get_mib_sta(struct hostap
+@@ -2017,6 +2018,7 @@ int ieee802_1x_get_mib_sta(struct hostap
        return len;
  }
  
                                struct sta_info *sta, int success)
 --- a/src/ap/wpa_auth.c
 +++ b/src/ap/wpa_auth.c
-@@ -2458,6 +2458,7 @@ static int wpa_cipher_bits(int cipher)
+@@ -2470,6 +2470,7 @@ static int wpa_cipher_bits(int cipher)
        }
  }
  
  
  #define RSN_SUITE "%02x-%02x-%02x-%d"
  #define RSN_SUITE_ARG(s) \
-@@ -2619,7 +2620,7 @@ int wpa_get_mib_sta(struct wpa_state_mac
+@@ -2633,7 +2634,7 @@ int wpa_get_mib_sta(struct wpa_state_mac
  
        return len;
  }
  {
 --- a/src/rsn_supp/wpa.c
 +++ b/src/rsn_supp/wpa.c
-@@ -1852,6 +1852,8 @@ static u32 wpa_cipher_suite(struct wpa_s
+@@ -1913,6 +1913,8 @@ static u32 wpa_cipher_suite(struct wpa_s
  }
  
  
  #define RSN_SUITE "%02x-%02x-%02x-%d"
  #define RSN_SUITE_ARG(s) \
  ((s) >> 24) & 0xff, ((s) >> 16) & 0xff, ((s) >> 8) & 0xff, (s) & 0xff
-@@ -1931,6 +1933,7 @@ int wpa_sm_get_mib(struct wpa_sm *sm, ch
+@@ -1992,6 +1994,7 @@ int wpa_sm_get_mib(struct wpa_sm *sm, ch
  
        return (int) len;
  }