iptables: drop iptables-utils and ip6tables-utils, ship needed symlinks in iptables...
[openwrt/staging/wigyori.git] / package / iptables / Makefile
index 94e3f58b0fdfc1bbd2a677822f16d2b848c1d60a..67dedca38ffa5994a4da5eb2ad39dcc707d32dc1 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,29 +9,32 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=iptables
-PKG_VERSION:=1.4.8
-PKG_RELEASE:=1
+PKG_VERSION:=1.4.10
+PKG_RELEASE:=4
 
-PKG_MD5SUM:=697ed89f37af4473a5f6349ba2700f2d
+PKG_MD5SUM:=f382fe693f0b59d87bd47bea65eca198
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
        ftp://ftp.be.netfilter.org/pub/netfilter/iptables/ \
        ftp://ftp.de.netfilter.org/pub/netfilter/iptables/ \
        ftp://ftp.no.netfilter.org/pub/netfilter/iptables/
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
   -include $(LINUX_DIR)/.config
   include $(INCLUDE_DIR)/netfilter.mk
-  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell grep 'NETFILTER' $(LINUX_DIR)/.config | md5s)
+  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell $(SH_FUNC) grep 'NETFILTER' $(LINUX_DIR)/.config | md5s)
 endif
 
 
 define Package/iptables/Default
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Firewall
   URL:=http://netfilter.org/
 endef
 
@@ -44,19 +47,32 @@ define Package/iptables
 $(call Package/iptables/Default)
   TITLE:=IPv4 firewall administration tool
   MENU:=1
-  DEPENDS+= +kmod-ipt-core +libiptc +libxtables
+  DEPENDS+= +kmod-ipt-core +libip4tc +libxtables
 endef
 
 define Package/iptables/description
 IPv4 firewall administration tool.
-Includes support for:
-- comment
-- limit
-- LOG
-- mac
-- multiport
-- REJECT
-- TCPMSS
+
+ Matches:
+  - icmp
+  - tcp
+  - udp
+  - comment
+  - limit
+  - mac
+  - multiport
+
+ Targets:
+  - ACCEPT
+  - DROP
+  - REJECT
+  - LOG
+  - TCPMSS
+
+ Tables:
+  - filter
+  - mangle
+
 endef
 
 define Package/iptables-mod-conntrack
@@ -66,10 +82,17 @@ endef
 
 define Package/iptables-mod-conntrack/description
 Basic iptables extensions for connection tracking.
-Includes:
-- state
-- raw
-- NOTRACK
+
+ Matches:
+  - state
+  - conntrack
+
+ Targets:
+  - NOTRACK
+
+ Tables:
+  - raw
+
 endef
 
 define Package/iptables-mod-conntrack-extra
@@ -79,10 +102,16 @@ endef
 
 define Package/iptables-mod-conntrack-extra/description
 Extra iptables extensions for connection tracking.
-Includes:
-- libipt_conntrack
-- libipt_helper
-- libipt_connmark/CONNMARK
+
+ Matches:
+  - connbytes
+  - connmark
+  - recent
+  - helper
+
+ Targets:
+  - CONNMARK
+
 endef
 
 define Package/iptables-mod-filter
@@ -92,20 +121,12 @@ endef
 
 define Package/iptables-mod-filter/description
 iptables extensions for packet content inspection.
-Includes:
-- libipt_string
-- libipt_layer7
-endef
+Includes support for:
 
-define Package/iptables-mod-imq
-$(call Package/iptables/Module, +kmod-ipt-imq)
-  TITLE:=IMQ support
-endef
+ Matches:
+  - layer7
+  - string
 
-define Package/iptables-mod-imq/description
-iptables extension for IMQ support.
-Includes:
-- libipt_IMQ
 endef
 
 define Package/iptables-mod-ipopt
@@ -115,18 +136,26 @@ endef
 
 define Package/iptables-mod-ipopt/description
 iptables extensions for matching/changing IP packet options.
-Includes:
-- libipt_CLASSIFY
-- libipt_dscp/DSCP
-- libipt_ecn/ECN
-- libipt_length
-- libipt_mac
-- libipt_mark/MARK
-- libipt_statistic
-- libipt_tcpmms
-- libipt_tos/TOS
-- libipt_ttl/TTL
-- libipt_unclean
+
+ Matches:
+  - dscp
+  - hashlimit
+  - ecn
+  - length
+  - mark
+  - statistic
+  - tcpmss
+  - time
+  - unclean
+  - hl
+
+ Targets:
+  - DSCP
+  - CLASSIFY
+  - ECN
+  - MARK
+  - HL
+
 endef
 
 define Package/iptables-mod-ipsec
@@ -136,22 +165,28 @@ endef
 
 define Package/iptables-mod-ipsec/description
 iptables extensions for matching ipsec traffic.
-Includes:
-- libipt_ah
-- libipt_esp
-- libipt_policy
+
+ Matches:
+  - ah
+  - esp
+  - policy
+
 endef
 
 define Package/iptables-mod-ipset
-$(call Package/iptables/Module, @LINUX_2_6)
+$(call Package/iptables/Module,)
   TITLE:=IPset iptables extensions
 endef
 
 define Package/iptables-mod-ipset/description
 IPset iptables extensions.
-Includes:
-- libipt_set
-- libipt_SET
+
+ Matches:
+  - set
+
+ Targets:
+  - SET
+
 endef
 
 define Package/iptables-mod-nat
@@ -161,10 +196,15 @@ endef
 
 define Package/iptables-mod-nat/description
 iptables extensions for basic NAT targets.
-Includes:
-- MASQUERADE
-- SNAT
-- DNAT
+
+ Targets:
+  - SNAT
+  - DNAT
+  - MASQUERADE
+
+ Tables:
+  - nat
+
 endef
 
 define Package/iptables-mod-nat-extra
@@ -174,8 +214,11 @@ endef
 
 define Package/iptables-mod-nat-extra/description
 iptables extensions for extra NAT targets.
-Includes:
-- REDIRECT
+
+ Targets:
+  - MIRROR
+  - NETMAP
+  - REDIRECT
 endef
 
 define Package/iptables-mod-ulog
@@ -185,8 +228,23 @@ endef
 
 define Package/iptables-mod-ulog/description
 iptables extensions for user-space packet logging.
-Includes:
-- libipt_ULOG
+
+ Targets:
+  - ULOG
+
+endef
+
+define Package/iptables-mod-hashlimit
+$(call Package/iptables/Module, +kmod-ipt-hashlimit)
+  TITLE:=hashlimit matching
+endef
+
+define Package/iptables-mod-hashlimit/description
+iptables extensions for hashlimit matching
+
+ Matches:
+  - hashlimit
+
 endef
 
 define Package/iptables-mod-iprange
@@ -196,8 +254,10 @@ endef
 
 define Package/iptables-mod-iprange/description
 iptables extensions for matching ip ranges.
-Includes:
-- libipt_iprange
+
+ Matches:
+  - iprange
+
 endef
 
 define Package/iptables-mod-extra
@@ -207,38 +267,99 @@ endef
 
 define Package/iptables-mod-extra/description
 Other extra iptables extensions.
-Includes:
-- libipt_owner
-- libipt_physdev
-- libipt_pkttype
-- libipt_recent
+
+ Matches:
+  - condition
+  - owner
+  - physdev (if ebtables is enabled)
+  - pkttype
+  - quota
+
 endef
 
-define Package/iptables-utils
-$(call Package/iptables/Module, )
-  TITLE:=iptables save and restore utilities
+define Package/iptables-mod-led
+$(call Package/iptables/Module, +kmod-ipt-led)
+  TITLE:=LED trigger iptables extension
+endef
+
+define Package/iptables-mod-led/description
+iptables extension for triggering a LED.
+
+ Targets:
+  - LED
+
+endef
+
+define Package/iptables-mod-tproxy
+$(call Package/iptables/Module, +kmod-ipt-tproxy)
+  TITLE:=Transparent proxy iptables extensions
+endef
+
+define Package/iptables-mod-tproxy/description
+Transparent proxy iptables extensions.
+
+ Matches:
+  - socket
+
+ Targets:
+  - TPROXY
+
+endef
+
+define Package/iptables-mod-tee
+$(call Package/iptables/Module, +kmod-ipt-tee)
+  TITLE:=TEE iptables extensions
+endef
+
+define Package/iptables-mod-tee/description
+TEE iptables extensions.
+
+ Targets:
+  - TEE
+
+endef
+
+define Package/iptables-mod-u32
+$(call Package/iptables/Module, +kmod-ipt-u32)
+  TITLE:=U32 iptables extensions
+endef
+
+define Package/iptables-mod-u32/description
+U32 iptables extensions.
+
+ Matches:
+  - u32
+
 endef
 
 define Package/ip6tables
 $(call Package/iptables/Default)
-  DEPENDS:=+kmod-ip6tables
+  DEPENDS:=+kmod-ip6tables +libip6tc +libxtables
   CATEGORY:=IPv6
   TITLE:=IPv6 firewall administration tool
   MENU:=1
 endef
 
-define Package/ip6tables-utils
+define Package/libiptc
 $(call Package/iptables/Default)
-  DEPENDS:=ip6tables
-  CATEGORY:=IPv6
-  TITLE:=ip6tables save and restore utilities
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+libip4tc +libip6tc
+  TITLE:=IPv4/IPv6 firewall - shared libiptc library (compatibility stub)
 endef
 
-define Package/libiptc
+define Package/libip4tc
+$(call Package/iptables/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=IPv4 firewall - shared libiptc library
+endef
+
+define Package/libip6tc
 $(call Package/iptables/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=IPv4/IPv6 firewall - shared libiptc library
+  TITLE:=IPv6 firewall - shared libiptc library
 endef
 
 define Package/libxtables
@@ -248,6 +369,12 @@ define Package/libxtables
  TITLE:=IPv4/IPv6 firewall - shared xtables library
 endef
 
+define Package/libipq
+  $(call Package/iptables/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=IPv4/IPv6 firewall - shared libipq library
+endef
 
 TARGET_CPPFLAGS := \
        -I$(PKG_BUILD_DIR)/include \
@@ -262,25 +389,16 @@ CONFIGURE_ARGS += \
        --enable-shared \
        --enable-devel \
        --enable-ipv6 \
+       --enable-libipq \
        --with-kernel="$(LINUX_DIR)" \
        --with-xtlibdir=/usr/lib/iptables
 
-IPTABLES_MAKEOPTS = \
-               $(TARGET_CONFIGURE_OPTS) \
-               COPT_FLAGS="$(TARGET_CFLAGS)" \
-               LDFLAGS="-rdynamic -static-libgcc" \
-               KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
-               KBUILD_OUTPUT="$(LINUX_DIR)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               $(MAKE_TARGETS)
-
-define Build/Compile
-       $(INSTALL_DIR) $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) $(IPTABLES_MAKEOPTS)
-       $(MAKE) -C $(PKG_BUILD_DIR) $(IPTABLES_MAKEOPTS) install
-       $(MAKE) -C $(PKG_BUILD_DIR)/libipq $(IPTABLES_MAKEOPTS)
-       $(MAKE) -C $(PKG_BUILD_DIR)/libipq $(IPTABLES_MAKEOPTS) install
-endef
+MAKE_FLAGS := \
+       $(TARGET_CONFIGURE_OPTS) \
+       COPT_FLAGS="$(TARGET_CFLAGS)" \
+       LDFLAGS="-rdynamic" \
+       KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
+       KBUILD_OUTPUT="$(LINUX_DIR)" \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
@@ -297,9 +415,9 @@ define Build/InstallDev
 
        $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxtables.{a,so*} $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libip*tc.{a,so*} $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libipq.a $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxtables.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libip*tc.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libipq.so* $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/xtables.pc $(1)/usr/lib/pkgconfig/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libiptc.pc $(1)/usr/lib/pkgconfig/
@@ -308,6 +426,8 @@ endef
 define Package/iptables/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/iptables $(1)/usr/sbin/
+       $(LN) iptables $(1)/usr/sbin/iptables-save
+       $(LN) iptables $(1)/usr/sbin/iptables-restore
        $(INSTALL_DIR) $(1)/usr/lib/iptables
        (cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
                for m in $(patsubst xt_%,ipt_%,$(IPT_BUILTIN)) $(patsubst ipt_%,xt_%,$(IPT_BUILTIN)); do \
@@ -318,28 +438,30 @@ define Package/iptables/install
        )
 endef
 
-define Package/iptables-utils/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/iptables-{save,restore} $(1)/usr/sbin/
-endef
-
 define Package/ip6tables/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ip6tables $(1)/usr/sbin/
+       $(LN) ip6tables $(1)/usr/sbin/ip6tables-save
+       $(LN) ip6tables $(1)/usr/sbin/ip6tables-restore
        $(INSTALL_DIR) $(1)/usr/lib/iptables
        (cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
                $(CP) libip6t_*.so $(1)/usr/lib/iptables/ \
        )
 endef
 
-define Package/ip6tables-utils/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ip6tables-{save,restore} $(1)/usr/sbin/
+define Package/libiptc/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libiptc.so* $(1)/usr/lib/
 endef
 
-define Package/libiptc/install
+define Package/libip4tc/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libip*tc.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libip4tc.so* $(1)/usr/lib/
+endef
+
+define Package/libip6tc/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libip6tc.so* $(1)/usr/lib/
 endef
 
 define Package/libxtables/install
@@ -347,6 +469,11 @@ define Package/libxtables/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxtables.so* $(1)/usr/lib/
 endef
 
+define Package/libipq/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libipq.so* $(1)/usr/lib/
+endef
+
 define BuildPlugin
   define Package/$(1)/install
        $(INSTALL_DIR) $$(1)/usr/lib/iptables
@@ -367,12 +494,10 @@ L7_INSTALL:=\
 
 
 $(eval $(call BuildPackage,iptables))
-$(eval $(call BuildPackage,iptables-utils))
 $(eval $(call BuildPlugin,iptables-mod-conntrack,$(IPT_CONNTRACK-m)))
 $(eval $(call BuildPlugin,iptables-mod-conntrack-extra,$(IPT_CONNTRACK_EXTRA-m)))
 $(eval $(call BuildPlugin,iptables-mod-extra,$(IPT_EXTRA-m)))
 $(eval $(call BuildPlugin,iptables-mod-filter,$(IPT_FILTER-m),$(L7_INSTALL)))
-$(eval $(call BuildPlugin,iptables-mod-imq,$(IPT_IMQ-m)))
 $(eval $(call BuildPlugin,iptables-mod-ipopt,$(IPT_IPOPT-m)))
 $(eval $(call BuildPlugin,iptables-mod-ipsec,$(IPT_IPSEC-m)))
 $(eval $(call BuildPlugin,iptables-mod-ipset,ipt_set ipt_SET))
@@ -380,7 +505,14 @@ $(eval $(call BuildPlugin,iptables-mod-nat,$(IPT_NAT-m)))
 $(eval $(call BuildPlugin,iptables-mod-nat-extra,$(IPT_NAT_EXTRA-m)))
 $(eval $(call BuildPlugin,iptables-mod-iprange,$(IPT_IPRANGE-m)))
 $(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
+$(eval $(call BuildPlugin,iptables-mod-hashlimit,$(IPT_HASHLIMIT-m)))
+$(eval $(call BuildPlugin,iptables-mod-led,$(IPT_LED-m)))
+$(eval $(call BuildPlugin,iptables-mod-tproxy,$(IPT_TPROXY-m)))
+$(eval $(call BuildPlugin,iptables-mod-tee,$(IPT_TEE-m)))
+$(eval $(call BuildPlugin,iptables-mod-u32,$(IPT_U32-m)))
 $(eval $(call BuildPackage,ip6tables))
-$(eval $(call BuildPackage,ip6tables-utils))
 $(eval $(call BuildPackage,libiptc))
+$(eval $(call BuildPackage,libip4tc))
+$(eval $(call BuildPackage,libip6tc))
 $(eval $(call BuildPackage,libxtables))
+$(eval $(call BuildPackage,libipq))