iptables: drop iptables-utils and ip6tables-utils, ship needed symlinks in iptables...
[openwrt/staging/wigyori.git] / package / iptables / Makefile
index b1ae19db1712e0425d0e1aa784222b227c27e8e1..67dedca38ffa5994a4da5eb2ad39dcc707d32dc1 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=iptables
 PKG_VERSION:=1.4.10
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_MD5SUM:=f382fe693f0b59d87bd47bea65eca198
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -52,14 +52,27 @@ endef
 
 define Package/iptables/description
 IPv4 firewall administration tool.
-Includes support for:
-- comment
-- limit
-- LOG
-- mac
-- multiport
-- REJECT
-- TCPMSS
+
+ Matches:
+  - icmp
+  - tcp
+  - udp
+  - comment
+  - limit
+  - mac
+  - multiport
+
+ Targets:
+  - ACCEPT
+  - DROP
+  - REJECT
+  - LOG
+  - TCPMSS
+
+ Tables:
+  - filter
+  - mangle
+
 endef
 
 define Package/iptables-mod-conntrack
@@ -69,10 +82,17 @@ endef
 
 define Package/iptables-mod-conntrack/description
 Basic iptables extensions for connection tracking.
-Includes:
-- state
-- raw
-- NOTRACK
+
+ Matches:
+  - state
+  - conntrack
+
+ Targets:
+  - NOTRACK
+
+ Tables:
+  - raw
+
 endef
 
 define Package/iptables-mod-conntrack-extra
@@ -82,10 +102,16 @@ endef
 
 define Package/iptables-mod-conntrack-extra/description
 Extra iptables extensions for connection tracking.
-Includes:
-- libipt_conntrack
-- libipt_helper
-- libipt_connmark/CONNMARK
+
+ Matches:
+  - connbytes
+  - connmark
+  - recent
+  - helper
+
+ Targets:
+  - CONNMARK
+
 endef
 
 define Package/iptables-mod-filter
@@ -95,9 +121,12 @@ endef
 
 define Package/iptables-mod-filter/description
 iptables extensions for packet content inspection.
-Includes:
-- libipt_string
-- libipt_layer7
+Includes support for:
+
+ Matches:
+  - layer7
+  - string
+
 endef
 
 define Package/iptables-mod-ipopt
@@ -107,18 +136,26 @@ endef
 
 define Package/iptables-mod-ipopt/description
 iptables extensions for matching/changing IP packet options.
-Includes:
-- libipt_CLASSIFY
-- libipt_dscp/DSCP
-- libipt_ecn/ECN
-- libipt_length
-- libipt_mac
-- libipt_mark/MARK
-- libipt_statistic
-- libipt_tcpmms
-- libipt_tos/TOS
-- libipt_ttl/TTL
-- libipt_unclean
+
+ Matches:
+  - dscp
+  - hashlimit
+  - ecn
+  - length
+  - mark
+  - statistic
+  - tcpmss
+  - time
+  - unclean
+  - hl
+
+ Targets:
+  - DSCP
+  - CLASSIFY
+  - ECN
+  - MARK
+  - HL
+
 endef
 
 define Package/iptables-mod-ipsec
@@ -128,10 +165,12 @@ endef
 
 define Package/iptables-mod-ipsec/description
 iptables extensions for matching ipsec traffic.
-Includes:
-- libipt_ah
-- libipt_esp
-- libipt_policy
+
+ Matches:
+  - ah
+  - esp
+  - policy
+
 endef
 
 define Package/iptables-mod-ipset
@@ -141,9 +180,13 @@ endef
 
 define Package/iptables-mod-ipset/description
 IPset iptables extensions.
-Includes:
-- libipt_set
-- libipt_SET
+
+ Matches:
+  - set
+
+ Targets:
+  - SET
+
 endef
 
 define Package/iptables-mod-nat
@@ -153,10 +196,15 @@ endef
 
 define Package/iptables-mod-nat/description
 iptables extensions for basic NAT targets.
-Includes:
-- MASQUERADE
-- SNAT
-- DNAT
+
+ Targets:
+  - SNAT
+  - DNAT
+  - MASQUERADE
+
+ Tables:
+  - nat
+
 endef
 
 define Package/iptables-mod-nat-extra
@@ -166,8 +214,11 @@ endef
 
 define Package/iptables-mod-nat-extra/description
 iptables extensions for extra NAT targets.
-Includes:
-- REDIRECT
+
+ Targets:
+  - MIRROR
+  - NETMAP
+  - REDIRECT
 endef
 
 define Package/iptables-mod-ulog
@@ -177,8 +228,10 @@ endef
 
 define Package/iptables-mod-ulog/description
 iptables extensions for user-space packet logging.
-Includes:
-- libipt_ULOG
+
+ Targets:
+  - ULOG
+
 endef
 
 define Package/iptables-mod-hashlimit
@@ -188,8 +241,10 @@ endef
 
 define Package/iptables-mod-hashlimit/description
 iptables extensions for hashlimit matching
-Includes:
-- libipt_hashlimit
+
+ Matches:
+  - hashlimit
+
 endef
 
 define Package/iptables-mod-iprange
@@ -199,8 +254,10 @@ endef
 
 define Package/iptables-mod-iprange/description
 iptables extensions for matching ip ranges.
-Includes:
-- libipt_iprange
+
+ Matches:
+  - iprange
+
 endef
 
 define Package/iptables-mod-extra
@@ -210,11 +267,14 @@ endef
 
 define Package/iptables-mod-extra/description
 Other extra iptables extensions.
-Includes:
-- libipt_owner
-- libipt_physdev
-- libipt_pkttype
-- libipt_recent
+
+ Matches:
+  - condition
+  - owner
+  - physdev (if ebtables is enabled)
+  - pkttype
+  - quota
+
 endef
 
 define Package/iptables-mod-led
@@ -224,8 +284,10 @@ endef
 
 define Package/iptables-mod-led/description
 iptables extension for triggering a LED.
-Includes:
-- libxt_LED
+
+ Targets:
+  - LED
+
 endef
 
 define Package/iptables-mod-tproxy
@@ -235,9 +297,13 @@ endef
 
 define Package/iptables-mod-tproxy/description
 Transparent proxy iptables extensions.
-Includes:
-- libxt_socket
-- libxt_TPROXY
+
+ Matches:
+  - socket
+
+ Targets:
+  - TPROXY
+
 endef
 
 define Package/iptables-mod-tee
@@ -247,8 +313,10 @@ endef
 
 define Package/iptables-mod-tee/description
 TEE iptables extensions.
-Includes:
-- libxt_TEE
+
+ Targets:
+  - TEE
+
 endef
 
 define Package/iptables-mod-u32
@@ -258,13 +326,10 @@ endef
 
 define Package/iptables-mod-u32/description
 U32 iptables extensions.
-Includes:
-- libxt_u32
-endef
 
-define Package/iptables-utils
-$(call Package/iptables/Module, )
-  TITLE:=iptables save and restore utilities
+ Matches:
+  - u32
+
 endef
 
 define Package/ip6tables
@@ -275,13 +340,6 @@ $(call Package/iptables/Default)
   MENU:=1
 endef
 
-define Package/ip6tables-utils
-$(call Package/iptables/Default)
-  DEPENDS:=ip6tables
-  CATEGORY:=IPv6
-  TITLE:=ip6tables save and restore utilities
-endef
-
 define Package/libiptc
 $(call Package/iptables/Default)
   SECTION:=libs
@@ -368,6 +426,8 @@ endef
 define Package/iptables/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/iptables $(1)/usr/sbin/
+       $(LN) iptables $(1)/usr/sbin/iptables-save
+       $(LN) iptables $(1)/usr/sbin/iptables-restore
        $(INSTALL_DIR) $(1)/usr/lib/iptables
        (cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
                for m in $(patsubst xt_%,ipt_%,$(IPT_BUILTIN)) $(patsubst ipt_%,xt_%,$(IPT_BUILTIN)); do \
@@ -378,29 +438,17 @@ define Package/iptables/install
        )
 endef
 
-define Package/iptables-utils/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/iptables-multi $(1)/usr/sbin/
-       $(LN) iptables-multi $(1)/usr/sbin/iptables-save
-       $(LN) iptables-multi $(1)/usr/sbin/iptables-restore
-endef
-
 define Package/ip6tables/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ip6tables $(1)/usr/sbin/
+       $(LN) ip6tables $(1)/usr/sbin/ip6tables-save
+       $(LN) ip6tables $(1)/usr/sbin/ip6tables-restore
        $(INSTALL_DIR) $(1)/usr/lib/iptables
        (cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
                $(CP) libip6t_*.so $(1)/usr/lib/iptables/ \
        )
 endef
 
-define Package/ip6tables-utils/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ip6tables-multi $(1)/usr/sbin/
-       $(LN) ip6tables-multi $(1)/usr/sbin/ip6tables-save
-       $(LN) ip6tables-multi $(1)/usr/sbin/ip6tables-restore
-endef
-
 define Package/libiptc/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libiptc.so* $(1)/usr/lib/
@@ -446,7 +494,6 @@ L7_INSTALL:=\
 
 
 $(eval $(call BuildPackage,iptables))
-$(eval $(call BuildPackage,iptables-utils))
 $(eval $(call BuildPlugin,iptables-mod-conntrack,$(IPT_CONNTRACK-m)))
 $(eval $(call BuildPlugin,iptables-mod-conntrack-extra,$(IPT_CONNTRACK_EXTRA-m)))
 $(eval $(call BuildPlugin,iptables-mod-extra,$(IPT_EXTRA-m)))
@@ -464,7 +511,6 @@ $(eval $(call BuildPlugin,iptables-mod-tproxy,$(IPT_TPROXY-m)))
 $(eval $(call BuildPlugin,iptables-mod-tee,$(IPT_TEE-m)))
 $(eval $(call BuildPlugin,iptables-mod-u32,$(IPT_U32-m)))
 $(eval $(call BuildPackage,ip6tables))
-$(eval $(call BuildPackage,ip6tables-utils))
 $(eval $(call BuildPackage,libiptc))
 $(eval $(call BuildPackage,libip4tc))
 $(eval $(call BuildPackage,libip6tc))