netfilter: add packages for arp and bridge tables of nftables
[openwrt/staging/wigyori.git] / package / kernel / linux / modules / netfilter.mk
index 410031b72ce5bc44bd3c3ddd656dba451882c730..ca3427152f5e00a945ba403f167ff29f1b8594c2 100644 (file)
@@ -907,8 +907,6 @@ define KernelPackage/nft-core
   KCONFIG:= \
        CONFIG_NFT_COMPAT=n \
        CONFIG_NFT_QUEUE=n \
-       CONFIG_NF_TABLES_ARP=n \
-       CONFIG_NF_TABLES_BRIDGE=n \
        $(KCONFIG_NFT_CORE)
 endef
 
@@ -919,6 +917,32 @@ endef
 $(eval $(call KernelPackage,nft-core))
 
 
+define KernelPackage/nft-arp
+  SUBMENU:=$(NF_MENU)
+  TITLE:=Netfilter nf_tables ARP table support
+  DEPENDS:=+kmod-nft-core
+  FILES:=$(foreach mod,$(NFT_ARP-m),$(LINUX_DIR)/net/$(mod).ko)
+  AUTOLOAD:=$(call AutoProbe,$(notdir $(NFT_ARP-m)))
+  KCONFIG:=$(KCONFIG_NFT_ARP)
+endef
+
+$(eval $(call KernelPackage,nft-arp))
+
+
+define KernelPackage/nft-bridge
+  SUBMENU:=$(NF_MENU)
+  TITLE:=Netfilter nf_tables bridge table support
+  DEPENDS:=+kmod-nft-core
+  FILES:=$(foreach mod,$(NFT_BRIDGE-m),$(LINUX_DIR)/net/$(mod).ko)
+  AUTOLOAD:=$(call AutoProbe,$(notdir $(NFT_BRIDGE-m)))
+  KCONFIG:= \
+       CONFIG_NF_LOG_BRIDGE=n \
+       $(KCONFIG_NFT_BRIDGE)
+endef
+
+$(eval $(call KernelPackage,nft-bridge))
+
+
 define KernelPackage/nft-nat
   SUBMENU:=$(NF_MENU)
   TITLE:=Netfilter nf_tables NAT support