procd: update to latest git HEAD
[openwrt/staging/wigyori.git] / package / libs / gettext-full / Makefile
index e07a158c28a19a2d1b0eaa595afff319afebc5af..db6aee75083fd5cd69dd293b7a697d8bc43c5ee3 100644 (file)
@@ -8,23 +8,23 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gettext-full
-PKG_VERSION:=0.19.6
+PKG_VERSION:=0.19.8.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=gettext-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gettext
-PKG_MD5SUM:=69d79254ee3b41df23f41c2f4fd720d9
+PKG_HASH:=105556dbc5c3fbbc2aa0edb46d22d055748b6f5c7cd7a8d99f8e7eb84e938be4
 PKG_BUILD_DIR:=$(BUILD_DIR)/gettext-$(PKG_VERSION)
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/gettext-$(PKG_VERSION)
 
-PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=GPL-3.0+
+PKG_CPE_ID:=cpe:/a:gnu:gettext
 
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=0
 PKG_BUILD_DEPENDS:=gettext-full/host
-PKG_CHECK_FORMAT_SECURITY:=0
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/host-build.mk
@@ -38,7 +38,7 @@ endef
 
 TARGET_CFLAGS += $(FPIC)
 ifneq ($(HOST_OS),Linux)
-  TARGET_CFLAGS += -I$(STAGING_DIR_HOST)/include
+  TARGET_CFLAGS += -I$(STAGING_DIR_HOSTPKG)/include
 endif
 ifdef CONFIG_USE_MUSL
   TARGET_CFLAGS += -D__UCLIBC__
@@ -47,18 +47,35 @@ endif
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
+       --disable-libasprintf \
        --disable-rpath \
        --enable-nls \
        --disable-java \
        --disable-native-java \
        --disable-openmp \
+       --disable-curses \
        --with-included-gettext \
        --without-libintl-prefix \
        --without-libexpat-prefix \
        --without-emacs
 
 HOST_CONFIGURE_ARGS += \
-       --with-included-libxml --without-libxml2-prefix --with-included-libcroco
+       --disable-shared \
+       --enable-static \
+       --disable-libasprintf \
+       --disable-rpath \
+       --disable-java \
+       --disable-native-java \
+       --disable-openmp \
+       --without-emacs \
+       --without-libxml2-prefix
+
+
+HOST_CONFIGURE_VARS += \
+       EMACS="no" \
+       am_cv_lib_iconv=no \
+       am_cv_func_iconv=no \
+       ac_cv_header_iconv_h=no \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib/libintl-full/include
@@ -69,6 +86,8 @@ define Build/InstallDev
 
        $(INSTALL_DIR) $(1)/usr/share/aclocal
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/aclocal/* $(1)/usr/share/aclocal/
+
+       $(SED) '/read dummy/d' $(STAGING_DIR_HOSTPKG)/bin/gettextize
 endef
 
 define Package/libintl-full/install