procd: update to latest git HEAD
[openwrt/staging/wigyori.git] / package / libs / libnl / Makefile
index 857bbe272cc72f6ec646864722e5997a51d0f231..5ac2280491259b22ed98998aee1cde688f1ff1e0 100644 (file)
@@ -8,20 +8,23 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnl
-PKG_VERSION:=3.2.21
+PKG_VERSION:=3.4.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.infradead.org/~tgr/libnl/files/
-PKG_MD5SUM:=6fe7136558a9071e70673dcda38545b3
+PKG_SOURCE_URL:=https://github.com/thom311/libnl/releases/download/libnl3_4_0
+PKG_HASH:=b7287637ae71c6db6f89e1422c995f0407ff2fe50cecd61a312b6a9b0921f5bf
 PKG_LICENSE:=LGPL-2.1
 
+PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libnl/default
   SECTION:=libs
   CATEGORY:=Libraries
-  URL:=http://people.suug.ch/~tgr/libnl/
+  URL:=http://www.infradead.org/~tgr/libnl/
 endef
 
 define Package/libnl-core
@@ -75,18 +78,14 @@ define Package/libnl/description
  message construction and parsing, object caching system, etc.
 endef
 
-TARGET_CFLAGS += -ffunction-sections $(FPIC)
+TARGET_CFLAGS += -ffunction-sections -fdata-sections $(FPIC)
 
-define Build/Compile
-       $(call Build/Compile/Default)
-       make -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               install
-endef
+CONFIGURE_ARGS += \
+       --disable-debug
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include/libnl $(1)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/libnl3/* $(1)/usr/include/libnl/
+       $(INSTALL_DIR) $(1)/usr/include/libnl3 $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/libnl3/* $(1)/usr/include/libnl3/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc $(1)/usr/lib/pkgconfig