firewall: compile with LTO enabled
[openwrt/staging/wigyori.git] / package / network / config / firewall / Makefile
index 42d40e955c53cd8d2379b0d1b062a306b2f93d6c..d5337a3381b4a0f80f5644ae45c12d73213ae305 100644 (file)
@@ -40,8 +40,8 @@ define Package/firewall/conffiles
 /etc/firewall.user
 endef
 
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
+TARGET_LDFLAGS += -Wl,--gc-sections -flto
 CMAKE_OPTIONS += $(if $(CONFIG_IPV6),,-DDISABLE_IPV6=1)
 
 define Package/firewall/install