ar71xx: wpa8630: change board name to tl-wpa8630
[openwrt/staging/wigyori.git] / target / linux / ar71xx / Makefile
index 5b17f90ecfaaf77e4445177923ff9a857ac9e220..a8df2b036e90d31e9577f24fe8ff8790de1d1617 100644 (file)
@@ -8,21 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx/AR7240/AR913x
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-SUBTARGETS:=generic nand
+BOARDNAME:=Atheros AR7xxx/AR9xxx
+FEATURES:=mips16
+CPU_TYPE:=24kc
+SUBTARGETS:=generic nand mikrotik
 
-LINUX_VERSION:=2.6.37.4
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-buttons kmod-button-hotplug swconfig
-
-define Target/Description
-       Build firmware images for Atheros AR71xx/AR913x based boards.
-endef
+       kmod-gpio-button-hotplug swconfig \
+       kmod-ath9k wpad-mini uboot-envtools
 
 $(eval $(call BuildTarget))