ar71xx: refresh 3.14 kernel patches
[openwrt/staging/wigyori.git] / target / linux / ar71xx / Makefile
index c123598e3b83455b32db18c9b739f576369e053f..c82890300562a2240c6b98ee1f4d12354b32759e 100644 (file)
@@ -9,21 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR7xxx/AR9xxx
-FEATURES:=squashfs targz mips16
-CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -mno-branch-likely
-SUBTARGETS:=generic nand
+FEATURES:=mips16
+CPU_TYPE=34kc
+SUBTARGETS:=generic nand mikrotik
 
-LINUX_VERSION:=3.10.3
+LINUX_VERSION:=3.14.18
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
-       kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
+       kmod-gpio-button-hotplug swconfig \
        kmod-ath9k wpad-mini uboot-envtools
 
-define Target/Description
-       Build firmware images for Atheros AR7xxx/AR9xxx based boards.
-endef
-
 $(eval $(call BuildTarget))