build: unify mips target cflags
[openwrt/staging/wigyori.git] / target / linux / ar71xx / Makefile
index 5b17f90ecfaaf77e4445177923ff9a857ac9e220..e80cc5961b6e1980d6da4503de96f6c509e79b55 100644 (file)
@@ -8,21 +8,22 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx/AR7240/AR913x
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+BOARDNAME:=Atheros AR7xxx/AR9xxx
+FEATURES:=squashfs targz mips16
+CPU_TYPE=34kc
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=2.6.37.4
+LINUX_VERSION:=3.10.12
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-buttons kmod-button-hotplug swconfig
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
+       kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
+       kmod-ath9k wpad-mini uboot-envtools
 
 define Target/Description
-       Build firmware images for Atheros AR71xx/AR913x based boards.
+       Build firmware images for Atheros AR7xxx/AR9xxx based boards.
 endef
 
 $(eval $(call BuildTarget))