ar71xx: fix initramfs image generation for Cameo933x profiles
[openwrt/staging/wigyori.git] / target / linux / ar71xx / image / Makefile
index b755a9d324fe54df0f3fdd29f6872bfb88505c35..e78679093da9d8ae32d111e0ca89b1bb9bdb6b0a 100644 (file)
@@ -386,7 +386,7 @@ define Image/Build/Cameo933x
 endef
 
 define Image/Build/Cameo933x/initramfs
-       $(call MkuImageLzma/initramfs,$(2),$(3),$(cameo933x_mtdlayout))
+       $(call MkuImageLzma/initramfs,$(2),$(3) $(cameo933x_mtdlayout))
 endef
 
 define Image/Build/Cameo933x_8M
@@ -816,6 +816,10 @@ define Image/Build/Template/squashfs-only/squashfs
        $(call Image/Build/$(1),squashfs,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
 endef
 
+define Image/Build/Template/squashfs-only/initramfs
+       $(call Image/Build/$(1)/initramfs,initramfs,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
+endef
+
 define Image/Build/Template/64k/loader
        $(call Image/Build/$(1)/loader,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
 endef