ar71xx: wpa8630: change board name to tl-wpa8630
[openwrt/staging/wigyori.git] / target / linux / ar71xx / modules.mk
index a6a13d2613c7cc64850dd2939be814258b995356..9ead8b451cec79c8848026b3b9485a85e186ced7 100644 (file)
@@ -5,6 +5,22 @@
 # See /LICENSE for more information.
 #
 
+define KernelPackage/leds-nu801
+  SUBMENU:=$(LEDS_MENU)
+  TITLE:=Meraki MR18 LED support
+  DEPENDS:=@TARGET_ar71xx
+  KCONFIG:=CONFIG_LEDS_NU801
+  FILES:=$(LINUX_DIR)/drivers/leds/leds-nu801.ko
+  AUTOLOAD:=$(call AutoLoad,60,leds-nu801)
+endef
+
+define KernelPackage/leds-nu801/description
+ Kernel module for the nu801 LED driver used on the Meraki MR18.
+endef
+
+$(eval $(call KernelPackage,leds-nu801))
+
+
 define KernelPackage/leds-rb750
   SUBMENU:=$(LEDS_MENU)
   TITLE:=RouterBOARD 750 LED support