kernel: clean up usb gadget support
[openwrt/staging/wigyori.git] / target / linux / at91 / Makefile
index e616467a5f92a4654d03ac97e6f4aa434f996fcc..bf62051d72ba78120d020bced3b0316bcd2e7cf9 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,15 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Atmel AT91
-FEATURES:=squashfs usb
+FEATURES:=squashfs targz ext2 usb usbgadget ubifs
+SUBTARGETS:=legacy sama5d3
 
-LINUX_VERSION:=2.6.25.17
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
-
-define Target/Description
-  Build fimware images for Figment Design Labs VersaLink board.
-endef
+DEFAULT_PACKAGES += kmod-usb-ohci kmod-at91-udc kmod-usb-gadget-eth
 
 $(eval $(call BuildTarget))