at91: do not build image for at91-q5xr5
[openwrt/staging/wigyori.git] / target / linux / at91 / image / legacy.mk
index 7fe388135d5dd80fdd27f15061c3ddcc41dd7371..ae3c163d94ae6acf43726a558a06016491186667 100644 (file)
@@ -1,3 +1,10 @@
+define Device/default-nand
+  BLOCKSIZE := 128k
+  PAGESIZE := 2048
+  SUBPAGESIZE := 512
+  MKUBIFS_OPTS := -m $$(PAGESIZE) -e 126KiB -c 2048
+endef
+
 define Device/at91sam9263ek
   $(Device/evaluation-dtb)
   DEVICE_TITLE := Atmel AT91SAM9263-EK
@@ -108,4 +115,19 @@ define Device/at91-q5xr5
   DEVICE_TITLE := Exegin Q5XR5
   KERNEL_SIZE := 2048k
 endef
-TARGET_DEVICES += at91-q5xr5
+#TARGET_DEVICES += at91-q5xr5
+
+define Device/wb45n
+  $(Device/evaluation-fit)
+  DEVICE_TITLE := Laird WB45N
+  DEVICE_PACKAGES := \
+       kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
+       kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
+       kmod-leds-gpio
+  BLOCKSIZE := 128k
+  PAGESIZE := 2048
+  SUBPAGESIZE := 2048
+  MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
+endef
+TARGET_DEVICES += wb45n
+