brcm2708: improve profiles and image generation
[openwrt/staging/wigyori.git] / target / linux / brcm2708 / bcm2708 / profiles / RaspberryPi.mk
index 94d0a068c065d7a835734ac798647405bea477f0..82a7910ba1089e6c2c324139d1b18c6c42d5cd78 100644 (file)
@@ -5,12 +5,26 @@
 # See /LICENSE for more information.
 #
 
-define Profile/RaspberryPi
+define Profile/Default
   NAME:=Raspberry Pi
 endef
+define Profile/Default/Description
+  Raspberry Pi
+endef
+$(eval $(call Profile,Default))
 
-define Profile/RaspberryPi/Description
-       Raspberry Pi board
+define Profile/RaspberryPi_B
+  NAME:=Raspberry Pi Model B
+endef
+define Profile/RaspberryPi_B/Description
+  Raspberry Pi Model B
 endef
+$(eval $(call Profile,RaspberryPi_B))
 
-$(eval $(call Profile,RaspberryPi))
+define Profile/RaspberryPi_BPlus
+  NAME:=Raspberry Pi Model B+
+endef
+define Profile/RaspberryPi_BPlus/Description
+  Raspberry Pi Model B+
+endef
+$(eval $(call Profile,RaspberryPi_BPlus))