kernel: update linux 3.8 to 3.8.13
[openwrt/staging/wigyori.git] / target / linux / cns3xxx / Makefile
index ae0ddd9ecf2c5ce920a79aa9ea305da7dc7f715e..4e8d6115f717567aa0b6f067a0c44736fde21af8 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=cns3xxx
 BOARDNAME:=Cavium Networks Econa CNS3xxx
-FEATURES:=squashfs fpu gpio
+FEATURES:=squashfs fpu gpio pcie usb usbgadget
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.8
+LINUX_VERSION:=3.8.13
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -24,4 +24,6 @@ endef
 
 KERNELNAME:="uImage"
 
+DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
+
 $(eval $(call BuildTarget))