kirkwood: add support for Netgear Stora (MS2110) NAS
[openwrt/staging/wigyori.git] / target / linux / kirkwood / image / Makefile
index b8cc92760da605b0727236d209ac0ac7e77a71d6..4bf5df64fea4395a0f48e2212e80155d0cd80865 100644 (file)
@@ -107,6 +107,15 @@ define Device/linksys_viper
 endef
 TARGET_DEVICES += linksys_viper
 
+define Device/netgear_stora
+  DEVICE_VENDOR := Netgear
+  DEVICE_MODEL := Stora
+  BOARD_NAME := netgear_stora
+  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4 \
+       kmod-rtc-pcf8563 kmod-hwmon-lm75 kmod-gpio-button-hotplug
+endef
+TARGET_DEVICES += netgear_stora
+
 define Device/raidsonic_ib-nas62x0
   DEVICE_VENDOR := RaidSonic
   DEVICE_MODEL := ICY BOX IB-NAS62x0