kernel: update 3.10 to 3.10.12
[openwrt/staging/wigyori.git] / target / linux / octeon / Makefile
index 20b3510ab53cff8a874d815a3b250353f5676bd1..12fcacb58554cf6d8329ce846e881b42945ac40c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,14 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci
-CFLAGS:=-Os -pipe -funit-at-a-time
+FEATURES:=squashfs jffs2 pci usb
+CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
+MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=2.6.30.3
+LINUX_VERSION:=3.10.12
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.