octeon: use new ext4/f2fs overlay support
[openwrt/staging/wigyori.git] / target / linux / octeon / image / Makefile
index e74b06dd4b887461a15fe2f63422466ab2663592..62e55dcf5d71a4a6fe5754315a942d0d388a203e 100644 (file)
@@ -7,59 +7,39 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Image/Prepare
-       # Workaround pre-SDK-1.9.0 u-boot versions not handling the .notes section
-       $(TARGET_CROSS)strip -R .notes $(KDIR)/vmlinux.elf -o $(KDIR)/vmlinux.elf.stripped
-endef
-
-define Image/BuildKernel/Template
-       $(CP) $(KDIR)/vmlinux.elf.stripped $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux.64
-       $(STAGING_DIR_HOST)/bin/patch-cmdline $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux.64 '$(strip $(2))'
-       md5sum $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux.64 | cut -d " " -f 1 | tee $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux.64.md5
+define Device/Default
+  PROFILES = Default $$(DEVICE_NAME)
+  KERNEL_NAME := vmlinux.elf
+  KERNEL_INITRAMFS_NAME := vmlinux-initramfs.elf
+  KERNEL := kernel-bin | strip-kernel | patch-cmdline
+  IMAGES := sysupgrade.tar
+  IMAGE/sysupgrade.tar/squashfs := append-rootfs | pad-extra 128k | sysupgrade-tar rootfs=$$$$@
+  IMAGE/sysupgrade.tar := sysupgrade-tar
 endef
 
-define Image/BuildKernel/Initramfs/Template
-       $(TARGET_CROSS)strip -R .notes $(KDIR)/vmlinux-initramfs.elf -o $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux-initramfs.elf
-       $(STAGING_DIR_HOST)/bin/patch-cmdline $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux-initramfs.elf '$(strip $(2))'
-endef
-
-ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro block2mtd.block2mtd=/dev/mmcblk0p2,65536,rootfs,5 root=/dev/mtdblock3 rootfstype=squashfs rootwait
-ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0),512k(boot1),64k@1024k(eeprom) block2mtd.block2mtd=/dev/sda2,65536,rootfs,5 root=/dev/mtdblock3 rootfstype=squashfs rootwait
-
-define Image/BuildKernel
-       $(call Image/BuildKernel/Template,generic,)
-       $(call Image/BuildKernel/Template,er,$(ER_CMDLINE))
-       $(call Image/BuildKernel/Template,erlite,$(ERLITE_CMDLINE))
-endef
-
-define Image/BuildKernel/Initramfs
-       $(call Image/BuildKernel/Initramfs/Template,generic,)
-       $(call Image/BuildKernel/Initramfs/Template,er,$(ER_CMDLINE))
-       $(call Image/BuildKernel/Initramfs/Template,erlite,$(ERLITE_CMDLINE))
-endef
-
-define Image/Build/sysupgrade
-       mkdir -p $(KDIR)/sysupgrade-$(1)/
-       echo "BOARD=$(1)" > $(KDIR)/sysupgrade-$(1)/CONTROL
-       $(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(2)-vmlinux.64 $(KDIR)/sysupgrade-$(1)/kernel
-       $(CP) $(KDIR)/root.$(3) $(KDIR)/sysupgrade-$(1)/root
-       (cd $(KDIR); $(TAR) cvf \
-               $(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(3)-sysupgrade.tar sysupgrade-$(1))
+define Build/strip-kernel
+       # Workaround pre-SDK-1.9.0 u-boot versions not handling the .notes section
+       $(TARGET_CROSS)strip -R .notes $@ -o $@.stripped && mv $@.stripped $@
 endef
 
-define Image/Build/ext4
-       $(call Image/Build/sysupgrade,erlite,generic,ext4)
+define Device/generic
+  FILESYSTEMS := ext4
+  DEVICE_TITLE := Generic
 endef
+TARGET_DEVICES += generic
 
-define Image/Build/squashfs
-       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-       $(call Image/Build/sysupgrade,er,er,squashfs)
-       $(call Image/Build/sysupgrade,erlite,erlite,squashfs)
+ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro root=/dev/mmcblk0p2 rootfstype=squashfs,ext4 rootwait
+define Device/er
+  CMDLINE := $(ER_CMDLINE) 
+  DEVICE_TITLE := Ubiquiti EdgeRouter
 endef
+TARGET_DEVICES += er
 
-define Image/Build
-       $(call Image/Build/$(1))
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0),512k(boot1),64k@1024k(eeprom) root=/dev/sda2 rootfstype=squashfs,ext4 rootwait
+define Device/erlite
+  CMDLINE := $(ERLITE_CMDLINE) 
+  DEVICE_TITLE := Ubiquiti EdgeRouter Lite
 endef
+TARGET_DEVICES += erlite
 
 $(eval $(call BuildImage))