kernel: clean up usb gadget support
[openwrt/staging/wigyori.git] / target / linux / omap24xx / profiles / 100-n810.mk
index 648b9e398166ba18f2c627b09a14f0ab57852871..bf2598c61ee3fa4391671c0de15577026d5b4445 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,15 +8,18 @@
 define Profile/n810-base
   NAME:=Nokia n810 (base)
   PACKAGES:= \
-       block-mount block-hotplug \
+       block-mount \
        gpsd \
-       ip iw wireless-tools kmod-p54-spi wpa-supplicant \
+       ip iw kmod-p54-spi wpa-supplicant \
        dnsmasq dropbear \
        pwrtray-backend \
        kmod-fs-vfat kmod-fs-msdos \
        kmod-input-evdev \
        kmod-leds-gpio \
-       kmod-usb-tahvo kmod-usb-eth-gadget kmod-usb-net kmod-usb-net-cdc-ether \
+       kmod-usb-tahvo kmod-usb-gadget-eth \
+       kmod-usb-net kmod-usb-net-cdc-ether kmod-usb-net-pegasus kmod-usb-net-rndis \
+       kmod-usb-storage kmod-usb-hid \
+       kmod-bluetooth kmod-bluetooth-hci-h4p bluez-utils bluez-hcidump \
        kmod-n810bm maemo-kexec calvaria \
        schedtool
 endef