kernel: update kernel to version 2.6.32.13 and 2.6.33.4
[openwrt/staging/wigyori.git] / target / linux / orion / Makefile
index 8b18cccb17cafb1e16026e5b48597c6c0845cb91..6227033847f42e90320e77e98dfebb71293d30df 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2008 OpenWrt.org
+#
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,17 +10,15 @@ ARCH:=arm
 BOARD:=orion
 BOARDNAME:=Marvell Orion
 FEATURES:=squashfs
+SUBTARGETS=generic harddisk
+CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
 
-LINUX_VERSION:=2.6.26-rc6
+LINUX_VERSION:=2.6.32.13
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-madwifi
+KERNELNAME:="uImage"
 
-define Kernel/Configure
-       $(call Kernel/Configure/Default)
-       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
-       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
-endef
+DEFAULT_PACKAGES += kmod-ath9k wpad-mini
 
 $(eval $(call BuildTarget))