build: unify powerpc target cflags
[openwrt/staging/wigyori.git] / target / linux / ppc40x / Makefile
index ef7e3fe2193e1a75279c4de45cab810cbac54af9..947c8ebb22e2a93dfe34ac985c31a420cfe10057 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
-FEATURES:=squashfs usb
-CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
+FEATURES:=squashfs
+CPU_TYPE:=405
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.30.4
-LINUX_KARCH:=powerpc
+LINUX_VERSION:=3.10.12
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -21,4 +21,6 @@ define Target/Description
        Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
+KERNELNAME:="uImage cuImage.magicbox cuImage.openrb"
+
 $(eval $(call BuildTarget))