ramips: fix MikroTik 750Gr3 ports MAC addresses
[openwrt/staging/wigyori.git] / target / linux / ramips / Makefile
index eafd2742e6aa086f5017406ce8416530d425caa7..864cfa543d053b0991cb0fe0c029f18221419b00 100644 (file)
@@ -8,19 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT3xxx
-SUBTARGETS:=rt305x mt7620 mt7621 mt7628 mt7688 rt3883 rt288x
+BOARDNAME:=MediaTek Ralink MIPS
+SUBTARGETS:=mt7620 mt7621 mt76x8 rt288x rt305x rt3883
 FEATURES:=squashfs gpio
-MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-KERNEL_PATCHVER:=3.18
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
+KERNEL_PATCHVER:=4.14
+KERNEL_TESTING_PATCHVER:=5.4
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += kmod-leds-gpio kmod-gpio-button-hotplug
+
 $(eval $(call BuildTarget))