ramips: fix BR-6478ACv2 support
[openwrt/staging/wigyori.git] / target / linux / ramips / image / mt7620.mk
index 0edea9f13ce13e3a98b4cc9cb0998049e3a1862a..c759a89f24b44237c07c55866e81ff468979a5d2 100644 (file)
@@ -475,7 +475,7 @@ define Device/tiny-ac
 endef
 TARGET_DEVICES += tiny-ac
 
-define Device/br-6478ac-v2
+define Device/edimax_br-6478ac-v2
   DTS := BR-6478AC-V2
   DEVICE_TITLE := Edimax BR-6478AC V2
   BLOCKSIZE := 64k
@@ -483,9 +483,9 @@ define Device/br-6478ac-v2
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
        edimax-header -s CSYS -m RN68 -f 0x70000 -S 0x01100000 | pad-rootfs | \
        append-metadata | check-size $$$$(IMAGE_SIZE)
-  DEVICE_PACKAGES := kmod-mt76
+  DEVICE_PACKAGES := kmod-mt76 kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
 endef
-TARGET_DEVICES += br-6478ac-v2
+TARGET_DEVICES += edimax_br-6478ac-v2
 
 define Device/tplink_c2-v1
   $(Device/Archer)