ramips: add support for XiaoYu XY-C5
[openwrt/staging/wigyori.git] / target / linux / ramips / image / rt3883.mk
index d96224e42501f2006029722d548494e2dfc2807f..de888a31b06fe1999e1770e9080341e8c5e7adf9 100644 (file)
@@ -8,6 +8,7 @@ endef
 define Device/asus_rt-n56u
   MTK_SOC := rt3883
   BLOCKSIZE := 64k
+  IMAGE_SIZE := 7872k
   IMAGE/sysupgrade.bin += | mkrtn56uimg -s
   DEVICE_VENDOR := Asus
   DEVICE_MODEL := RT-N56U
@@ -23,7 +24,7 @@ define Device/belkin_f9k1109v1
   DEVICE_MODEL := F9K1109
   DEVICE_VARIANT := Version 1.0
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
-  IMAGE_SIZE := 7224k
+  IMAGE_SIZE := 7808k
   KERNEL := kernel-bin | append-dtb | lzma -d16 | uImage lzma
   # Stock firmware checks for this uImage image name during upload.
   UIMAGE_NAME := N750F9K1103VB
@@ -34,6 +35,7 @@ define Device/dlink_dir-645
   $(Device/seama)
   MTK_SOC := rt3883
   BLOCKSIZE := 4k
+  IMAGE_SIZE := 7872k
   KERNEL := $(KERNEL_DTB)
   SEAMA_SIGNATURE := wrgn39_dlob.hans_dir645
   DEVICE_VENDOR := D-Link
@@ -60,6 +62,7 @@ TARGET_DEVICES += edimax_br-6475nd
 define Device/loewe_wmdr-143n
   MTK_SOC := rt3883
   BLOCKSIZE := 64k
+  IMAGE_SIZE := 7872k
   DEVICE_VENDOR := Loewe
   DEVICE_MODEL := WMDR-143N
   SUPPORTED_DEVICES += wmdr-143n
@@ -81,6 +84,7 @@ define Device/samsung_cy-swr1100
   $(Device/seama)
   MTK_SOC := rt3883
   BLOCKSIZE := 64k
+  IMAGE_SIZE := 7872k
   KERNEL := $(KERNEL_DTB)
   SEAMA_SIGNATURE := wrgnd10_samsung_ss815
   DEVICE_VENDOR := Samsung
@@ -107,6 +111,7 @@ TARGET_DEVICES += sitecom_wlr-6000
 define Device/trendnet_tew-691gr
   MTK_SOC := rt3883
   BLOCKSIZE := 64k
+  IMAGE_SIZE := 7872k
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
        umedia-header 0x026910
@@ -120,6 +125,7 @@ TARGET_DEVICES += trendnet_tew-691gr
 define Device/trendnet_tew-692gr
   MTK_SOC := rt3883
   BLOCKSIZE := 64k
+  IMAGE_SIZE := 7872k
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
        umedia-header 0x026920