ramips: add support for ALFA Network Tube-E4G
[openwrt/staging/wigyori.git] / toolchain / Makefile
index 409955c23a9c941387c92499f5270d69a973cdd2..0336b2f72cee18fefa66cce218c553b9b99a6e30 100644 (file)
@@ -29,7 +29,7 @@
 curdir:=toolchain
 
 # subdirectories to descend into
-$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/initial gcc/final $(LIBC) fortify-headers) $(if $(CONFIG_YASM),yasm)
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/initial gcc/final $(LIBC) fortify-headers) $(if $(CONFIG_NASM),nasm)
 ifdef CONFIG_USE_UCLIBC
   $(curdir)/builddirs += $(LIBC)/utils
 endif
@@ -70,6 +70,7 @@ endif
 endif
 
 ifdef CONFIG_BUILDBOT
+ifneq ($(wildcard $(TOPDIR)/.git),)
   $(TOOLCHAIN_DIR)/stamp/.ver_check: $(TMP_DIR)/.build
        cd "$(TOPDIR)"; git log --format=%h -1 toolchain > $(TMP_DIR)/.ver_check
        cmp -s $(TMP_DIR)/.ver_check $@ || { \
@@ -80,6 +81,7 @@ ifdef CONFIG_BUILDBOT
 
 $(TOOLCHAIN_DIR)/info.mk $(STAGING_DIR)/.prepared: $(TOOLCHAIN_DIR)/stamp/.ver_check
 endif
+endif
 
 # prerequisites for the individual targets
 $(curdir)/ := .config prereq