fix build breakage introduced by [32142]
[openwrt/staging/wigyori.git] / tools / e2fsprogs / Makefile
index 413e965a0ecc1d48f44dce305c8fb0ceb6699441..bf5e12ff806ba9b03d6b84bbe19ba304dac30c1b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.41.13
-PKG_MD5SUM:=7508a192c7a9471e2128424f4eafac1c
+PKG_VERSION:=1.42.3
+PKG_MD5SUM:=73431146f58d40fe1375aba2060f0da8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -25,11 +25,15 @@ CONFIGURE_ARGS += \
        --disable-rpath \
        --enable-elf-shlibs \
        --enable-dynamic-e2fsck \
-       --disable-tls
+       --disable-tls \
+       --disable-nls
 
 define Host/Install
        $(Host/Install/Default)
        $(MAKE) -C $(HOST_BUILD_DIR)/lib/uuid install
+       mkdir -p $(STAGING_DIR_HOST)/include/e2fsprogs
+       $(CP) $(STAGING_DIR_HOST)/include/uuid $(STAGING_DIR_HOST)/include/e2fsprogs/
+       rm -rf $(STAGING_DIR_HOST)/include/uuid
        $(INSTALL_DATA) $(HOST_BUILD_DIR)/lib/uuid/libuuid.a $(STAGING_DIR_HOST)/lib/
 endef