clean up gmp and mpfr
[openwrt/staging/wigyori.git] / tools / gmp / Makefile
index 42646716b5c992bd99fd4c21c87f02ee33df4ef1..3356ae9dd1c45bc97eff3f163394084cef0588f8 100644 (file)
@@ -15,28 +15,10 @@ PKG_MD5SUM:=
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-       ./configure \
-         --prefix=$(STAGING_DIR_HOST) \
-         --build=$(GNU_HOST_NAME) \
-         --enable-static \
-         --disable-shared \
-         --enable-cxx \
-         --enable-mpbsd \
-       );
-endef
-
-define Build/Compile
-       make -C $(PKG_BUILD_DIR) all
-endef
-
-define Build/Install
-       make -C $(PKG_BUILD_DIR) install
-endef
-
-define Build/Clean
-       rm -rf $(PKG_BUILD_DIR)
-endef
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --enable-cxx \
+       --enable-mpbsd
 
 $(eval $(call HostBuild))