tools/mkimage: use http download server (fixes FS#2052)
[openwrt/staging/wigyori.git] / tools / mkimage / Makefile
index c7e1dfd6720cb3c5f891c339e7815cafd1c7731f..fbcf87cfc6fac4f149c2dc683017fb3f765bd5ce 100644 (file)
@@ -10,9 +10,7 @@ PKG_NAME:=mkimage
 PKG_VERSION:=2018.03
 
 PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=\
-       http://mirror2.openwrt.org/sources \
-       ftp://ftp.denx.de/pub/u-boot
+PKG_SOURCE_URL:=http://ftp.denx.de/pub/u-boot
 PKG_HASH:=7e7477534409d5368eb1371ffde6820f0f79780a1a1f676161c48442cb303dfd
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
@@ -30,6 +28,7 @@ define Host/Compile
                HOSTCFLAGS="$(HOST_CFLAGS)" \
                HOSTLDFLAGS="$(HOST_LDFLAGS)" \
                no-dot-config-targets=tools-only \
+               CONFIG_MKIMAGE_DTC_PATH=dtc \
                CONFIG_FIT_SIGNATURE=y \
                tools-only
 endef