tools/mpfr: update to 3.1.3
[openwrt/staging/wigyori.git] / tools / mpfr / Makefile
index 84dc9ec29fe56d8d809e3bb892e353638edec959..16624a7a6a580fd9b74fc761e1049b687f902f72 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,35 +7,21 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpfr
-PKG_VERSION:=2.3.2
+PKG_VERSION:=3.1.3
 
-PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-current/
+PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION) \
+               @GNU/mpfr
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=527147c097874340cb9cee0579dacf3b
+PKG_MD5SUM:=5fdfa3cfa5c86514ee4a241a1affa138
 
-include $(INCLUDE_DIR)/host-build.mk
-
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-       ./configure \
-         --prefix=$(STAGING_DIR_HOST) \
-         --build=$(GNU_HOST_NAME) \
-         --enable-static \
-         --disable-shared \
-         --with-gmp=$(STAGING_DIR_HOST) \
-       );
-endef
+HOST_BUILD_PARALLEL:=1
+HOST_FIXUP:=autoreconf
 
-define Build/Compile
-       make -C $(PKG_BUILD_DIR) all
-endef
-
-define Build/Install
-       make -C $(PKG_BUILD_DIR) install
-endef
+include $(INCLUDE_DIR)/host-build.mk
 
-define Build/Clean
-       rm -rf $(PKG_BUILD_DIR)
-endef
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --with-gmp=$(STAGING_DIR_HOST)
 
 $(eval $(call HostBuild))