give Aruba some love - add support for the combined flash layout
authorImre Kaloz <kaloz@openwrt.org>
Sun, 20 May 2007 18:51:23 +0000 (18:51 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Sun, 20 May 2007 18:51:23 +0000 (18:51 +0000)
SVN-Revision: 7283

target/linux/aruba-2.6/Makefile
target/linux/aruba-2.6/config/default
target/linux/aruba-2.6/image/Makefile
target/linux/aruba-2.6/patches/000-aruba.patch

index c53964da8ac9feffeb49701c050fc0988444369f..35645b81020604d70ffe2cfea6a50cb7f3bd2e28 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=aruba
 BOARDNAME:=Aruba
-FEATURES:=jffs2
+FEATURES:=squashfs jffs2
 
 define Target/Description
        Build firmware images for Aruba boards
index 9c5ec0750d7e5c0e0e3103dbd7b6a4fbd26969ef..6ff30a9d84b97918b45cbe5fde25fba49b3b5bc1 100644 (file)
@@ -67,7 +67,7 @@ CONFIG_MACH_ARUBA=y
 # CONFIG_MACH_DECSTATION is not set
 # CONFIG_MACH_JAZZ is not set
 # CONFIG_MACH_VR41XX is not set
-CONFIG_MINI_FO=m
+CONFIG_MINI_FO=y
 CONFIG_MIPS=y
 # CONFIG_MIPS_ATLAS is not set
 # CONFIG_MIPS_BOSPORUS is not set
@@ -151,6 +151,7 @@ CONFIG_MTD_PHYSMAP_START=0x1fc00000
 # CONFIG_MTD_REDBOOT_PARTS is not set
 # CONFIG_MTD_ROM is not set
 # CONFIG_MTD_SLRAM is not set
+CONFIG_MTD_SPLIT_ROOTFS=y
 CONFIG_NATSEMI=y
 # CONFIG_NE2K_PCI is not set
 # CONFIG_NET_VENDOR_3COM is not set
index e486b30ef2058251afd4d47d364afee6527d7f36..7773f6a49e59305614b4df241d82007e685020f2 100644 (file)
@@ -31,11 +31,18 @@ define Image/BuildKernel
 endef
 
 define Image/Build/jffs2-64k
-       @dd if=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari of=$(KDIR)/image.tmp bs=655360 conv=sync
+       @dd if=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari of=$(KDIR)/image.tmp bs=786432 conv=sync
        @cat $(KDIR)/root.$(1) >> $(KDIR)/image.tmp
        mv $(KDIR)/image.tmp $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(patsubst jffs2-%,jffs2,$(1)).bin
 endef
 
+define Image/Build/squashfs
+       @dd if=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari of=$(KDIR)/image.tmp bs=786432 conv=sync
+       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+       @cat $(KDIR)/root.$(1) >> $(KDIR)/image.tmp
+       @dd if=$(KDIR)/image.tmp of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin bs=64k conv=sync
+endef
+
 define Image/Build
        $(call Image/Build/$(1),$(1))
 endef
index 9954a492bd3035bd9920438c5fa46c1d4da995a8..1f61424b493e1a3558967ef253fbecc01819583f 100644 (file)
@@ -630,9 +630,9 @@ diff -Nur linux-2.6.17/arch/mips/aruba/prom.c linux-2.6.17-owrt/arch/mips/aruba/
 +
 +/* Kernel Boot parameters */
 +static unsigned char bootparm[] = 
-+      "init=/etc/preinit "
-+      "mtdparts=physmap-flash.0:3520k@0x080000(zImage),2752k@0x140000(JFFS2),8k@0x3f8000(NVRAM) "
-+      "console=ttyS0,9600 root=/dev/mtdblock1 rootfstype=jffs2 ";
++      "init=/etc/preinit noinitrd "
++      "mtdparts=physmap-flash.0:3520k@0x080000(kernel),2752k@0x140000(rootfs),8k@0x3f8000(NVRAM) "
++      "console=ttyS0,9600 root=/dev/mtdblock1 rootfstype=squashfs,jffs2 ";
 +
 +extern unsigned long mips_machgroup;
 +extern unsigned long mips_machtype;