imagebuilder: make submake invocations less verbose
authorJo-Philipp Wich <jo@mein.io>
Mon, 1 Aug 2016 16:26:05 +0000 (18:26 +0200)
committerJo-Philipp Wich <jo@mein.io>
Wed, 1 Feb 2017 23:13:49 +0000 (00:13 +0100)
Use silent make invocations for sub-makes like build_image or checksum to
avoid bloating the IB output with non-status info.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/imagebuilder/files/Makefile

index af633b21636358c40e83ab7c83279b1733b3fb8d..baa0e1f271993d1d063c55f045cf7eaf413559f7 100644 (file)
@@ -123,9 +123,9 @@ _call_image: staging_dir/host/.prereq-build
 ifneq ($(USER_FILES),)
        $(MAKE) copy_files
 endif
-       $(MAKE) package_postinst
-       $(MAKE) build_image
-       $(MAKE) checksum
+       $(MAKE) -s package_postinst
+       $(MAKE) -s build_image
+       $(MAKE) -s checksum
 
 package_index: FORCE
        @echo
@@ -194,7 +194,7 @@ ifneq ($(PROFILE),)
   endif
 endif
        (unset PROFILE FILES PACKAGES MAKEFLAGS; \
-       $(MAKE) _call_image \
+       $(MAKE) -s _call_image \
                $(if $(PROFILE),USER_PROFILE="$(PROFILE_FILTER)") \
                $(if $(FILES),USER_FILES="$(FILES)") \
                $(if $(PACKAGES),USER_PACKAGES="$(PACKAGES)") \